CVE-2021-35939
CVE-2021-35939
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
It was found that the fix for CVE-2017-7500 and CVE-2017-7501 was incomplete: the check was only implemented for the parent directory of the file to be created. A local unprivileged user who owns another ancestor directory could potentially use this flaw to gain root privileges. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
CVSS 6.7 · Media · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
rpm
- Versiones
- Fixed in RPM-v4.18: Afectada
Sin corrección publicada
rpm Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.18.0+dfsg-1
Actualiza a 4.18.0+dfsg-1
rpm Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.18.0+dfsg-1
Actualiza a 4.18.0+dfsg-1
rpm Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.18.0+dfsg-1
Actualiza a 4.18.0+dfsg-1
rpm Ubuntu:Pro:14.04:LTS
- Versiones
- 4.11.1-2
- 4.11.1-3
- 4.11.1-3ubuntu0.1
- 4.11.1-3ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rpm Ubuntu:Pro:16.04:LTS
- Versiones
- 4.12.0.1+dfsg1-3build2
- 4.12.0.1+dfsg1-3build3
- 4.12.0.1+dfsg1-3ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rpm Ubuntu:Pro:18.04:LTS
- Versiones
- 4.12.0.2+dfsg1-2build2
- 4.14.0+dfsg1-2
- 4.14.1+dfsg1-2
- 4.14.1+dfsg1-2ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rpm Ubuntu:Pro:20.04:LTS
- Versiones
- 4.14.2.1+dfsg1-1
- 4.14.2.1+dfsg1-1build1
- 4.14.2.1+dfsg1-1build2
- 4.14.2.1+dfsg1-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rpm Ubuntu:22.04:LTS
- Versiones
- 4.16.1.2+dfsg1-3ubuntu1
- 4.16.1.2+dfsg1-3ubuntu3
- 4.17.0+dfsg1-1
- 4.17.0+dfsg1-3
- 4.17.0+dfsg1-4
- 4.17.0+dfsg1-4build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rpm Ubuntu:24.04:LTS
- Versiones
- 4.18.0+dfsg-1build1
- 4.18.0+dfsg-1build2
- 4.18.2+dfsg-1
- 4.18.2+dfsg-2
- 4.18.2+dfsg-2.1build1
- 4.18.2+dfsg-2.1build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rpm Ubuntu:25.10
- Versiones
- 4.20.1+dfsg-1
- 4.20.1+dfsg-2
- 4.20.1+dfsg-2build1
- 4.20.1+dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rpm Ubuntu:26.10
- Versiones
- 6.0.1-1build1
- 6.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rpm Ubuntu:26.04:LTS
- Versiones
- 4.20.1+dfsg-3
- 6.0.0-2
- 6.0.1-1
- 6.0.1-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://rpm.org/wiki/Releases/4.18.0
- https://github.com/rpm-software-management/rpm/pull/1919
- https://bugzilla.redhat.com/show_bug.cgi?id=1964129
- https://github.com/rpm-software-management/rpm/commit/96ec957e281220f8e137a2d5eb23b83a6377d556
- https://access.redhat.com/security/cve/CVE-2021-35939
- https://security.gentoo.org/glsa/202210-22
- https://nvd.nist.gov/vuln/detail/CVE-2021-35939