CVE-2021-3620
CVE-2021-3620
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A flaw was found in Ansible Engine's ansible-connection module, where sensitive information such as the Ansible user credentials is disclosed by default in the traceback error message. The highest threat from this vulnerability is to confidentiality.
CVSS 6.8 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
ansible
- Versiones
- Fixed in Ansible Engine v2.9.27: Afectada
Sin corrección publicada
ansible Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.4.0-1
Actualiza a 5.4.0-1
ansible Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.4.0-1
Actualiza a 5.4.0-1
ansible Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.4.0-1
Actualiza a 5.4.0-1
ansible-core Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.12.0-1
Actualiza a 2.12.0-1
ansible-core Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.12.0-1
Actualiza a 2.12.0-1
ansible-core Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.12.0-1
Actualiza a 2.12.0-1
ansible PyPI
- Versiones
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0
- 2.0.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- 2.1.4.0
- 2.1.5.0
- 2.1.6.0
- 2.2.0.0
- 2.2.1.0
- 2.2.2.0
- 2.2.3.0
- 2.3.0.0
- 2.3.1.0
- 2.3.2.0
- 2.3.3.0
- 2.4.0.0
- 2.4.1.0
- 2.4.2.0
- 2.4.3.0
- 2.4.4.0
- 2.4.5.0
- 2.4.6.0
- 2.5.0
- 2.5.0a1
- 2.5.0b1
- 2.5.0b2
- 2.5.0rc1
- 2.5.0rc2
- 2.5.0rc3
- 2.5.1
- 2.5.10
- 2.5.11
- 2.5.12
- 2.5.13
- 2.5.14
- 2.5.15
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- 2.6.0
- 2.6.0a1
- 2.6.0a2
- 2.6.0rc1
- 2.6.0rc2
- 2.6.0rc3
- 2.6.0rc4
- 2.6.0rc5
- 2.6.1
- 2.6.10
- 2.6.11
- 2.6.12
- 2.6.13
- 2.6.14
- 2.6.15
- 2.6.16
- 2.6.17
- 2.6.18
- 2.6.19
- 2.6.2
- 2.6.20
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- 2.7.0
- 2.7.0.dev0
- 2.7.0a1
- 2.7.0b1
- 2.7.0rc1
- 2.7.0rc2
- 2.7.0rc3
- 2.7.0rc4
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.13
- 2.7.14
- 2.7.15
- 2.7.16
- 2.7.17
- 2.7.18
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- 2.8.0
- 2.8.0a1
- 2.8.0b1
- 2.8.0rc1
- 2.8.0rc2
- 2.8.0rc3
- 2.8.1
- 2.8.10
- 2.8.11
- 2.8.12
- 2.8.13
- 2.8.14
- 2.8.15
- 2.8.16
- 2.8.16rc1
- 2.8.17
- 2.8.17rc1
- 2.8.18
- 2.8.18rc1
- 2.8.19
- 2.8.19rc1
- 2.8.2
- 2.8.20
- 2.8.20rc1
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.8.9
- 2.9.0
- 2.9.0b1
- 2.9.0rc1
- 2.9.0rc2
- 2.9.0rc3
- 2.9.0rc4
- 2.9.0rc5
- 2.9.1
- 2.9.10
- 2.9.11
- 2.9.12
- 2.9.13
- 2.9.14
- 2.9.14rc1
- 2.9.15
- 2.9.15rc1
- 2.9.16
- 2.9.16rc1
- 2.9.17
- 2.9.17rc1
- 2.9.18
- 2.9.18rc1
- 2.9.19
- 2.9.19rc1
- 2.9.2
- 2.9.20
- 2.9.20rc1
- 2.9.21
- 2.9.21rc1
- 2.9.22
- 2.9.22rc1
- 2.9.23
- 2.9.23rc1
- 2.9.24
- 2.9.24rc1
- 2.9.25
- 2.9.25rc1
- 2.9.26
- 2.9.26rc1
- 2.9.27rc1
- 2.9.3
- 2.9.4
- 2.9.5
- 2.9.6
- 2.9.7
- 2.9.8
- 2.9.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.9.27
Actualiza a 2.9.27
ansible PyPI
- Versiones
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0
- 2.0.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- 2.1.4.0
- 2.1.5.0
- 2.1.6.0
- 2.2.0.0
- 2.2.1.0
- 2.2.2.0
- 2.2.3.0
- 2.3.0.0
- 2.3.1.0
- 2.3.2.0
- 2.3.3.0
- 2.4.0.0
- 2.4.1.0
- 2.4.2.0
- 2.4.3.0
- 2.4.4.0
- 2.4.5.0
- 2.4.6.0
- 2.5.0
- 2.5.0a1
- 2.5.0b1
- 2.5.0b2
- 2.5.0rc1
- 2.5.0rc2
- 2.5.0rc3
- 2.5.1
- 2.5.10
- 2.5.11
- 2.5.12
- 2.5.13
- 2.5.14
- 2.5.15
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- 2.6.0
- 2.6.0a1
- 2.6.0a2
- 2.6.0rc1
- 2.6.0rc2
- 2.6.0rc3
- 2.6.0rc4
- 2.6.0rc5
- 2.6.1
- 2.6.10
- 2.6.11
- 2.6.12
- 2.6.13
- 2.6.14
- 2.6.15
- 2.6.16
- 2.6.17
- 2.6.18
- 2.6.19
- 2.6.2
- 2.6.20
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- 2.7.0
- 2.7.0.dev0
- 2.7.0a1
- 2.7.0b1
- 2.7.0rc1
- 2.7.0rc2
- 2.7.0rc3
- 2.7.0rc4
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.13
- 2.7.14
- 2.7.15
- 2.7.16
- 2.7.17
- 2.7.18
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- 2.8.0
- 2.8.0a1
- 2.8.0b1
- 2.8.0rc1
- 2.8.0rc2
- 2.8.0rc3
- 2.8.1
- 2.8.10
- 2.8.11
- 2.8.12
- 2.8.13
- 2.8.14
- 2.8.15
- 2.8.16
- 2.8.16rc1
- 2.8.17
- 2.8.17rc1
- 2.8.18
- 2.8.18rc1
- 2.8.19
- 2.8.19rc1
- 2.8.2
- 2.8.20
- 2.8.20rc1
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.8.9
- 2.9.0
- 2.9.0b1
- 2.9.0rc1
- 2.9.0rc2
- 2.9.0rc3
- 2.9.0rc4
- 2.9.0rc5
- 2.9.1
- 2.9.10
- 2.9.11
- 2.9.12
- 2.9.13
- 2.9.14
- 2.9.14rc1
- 2.9.15
- 2.9.15rc1
- 2.9.16
- 2.9.16rc1
- 2.9.17
- 2.9.17rc1
- 2.9.18
- 2.9.18rc1
- 2.9.19
- 2.9.19rc1
- 2.9.2
- 2.9.20
- 2.9.20rc1
- 2.9.21
- 2.9.21rc1
- 2.9.22
- 2.9.22rc1
- 2.9.23
- 2.9.23rc1
- 2.9.24
- 2.9.24rc1
- 2.9.25
- 2.9.25rc1
- 2.9.26
- 2.9.26rc1
- 2.9.27rc1
- 2.9.3
- 2.9.4
- 2.9.5
- 2.9.6
- 2.9.7
- 2.9.8
- 2.9.9
- Intervalos de versiones afectados
- GIT: < fe28767970c8ec62aabe493c46b53a5de1e5fac0
- ECOSYSTEM: < 2.9.27
Actualiza a 2.9.27
ansible Ubuntu:Pro:20.04:LTS
- Versiones
- 2.8.3+dfsg-1
- 2.8.6+dfsg-1
- 2.9.2+dfsg-1
- 2.9.4+dfsg-1
- 2.9.6+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.9.6+dfsg-1ubuntu0.1~esm1
Actualiza a 2.9.6+dfsg-1ubuntu0.1~esm1
ansible Ubuntu:Pro:22.04:LTS
- Versiones
- 2.10.7+merged+base+2.10.8+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.10.7+merged+base+2.10.8+dfsg-1ubuntu0.1~esm1
Actualiza a 2.10.7+merged+base+2.10.8+dfsg-1ubuntu0.1~esm1
ansible Ubuntu:24.04:LTS
- Versiones
- 7.7.0+dfsg-1
- 7.7.0+dfsg-3
- 9.2.0+dfsg-0ubuntu4
- 9.2.0+dfsg-0ubuntu5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ansible Ubuntu:25.10
- Versiones
- 11.2.0+dfsg-1
- 12.0.0~a2+dfsg-1
- 12.0.0~a4+dfsg-1
- 12.0.0~a6+dfsg-1
- 12.0.0~b1+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ansible Ubuntu:26.10
- Versiones
- 13.1.0+dfsg-1ubuntu1
- 13.4.0+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ansible Ubuntu:26.04:LTS
- Versiones
- 12.0.0~b1+dfsg-1
- 12.0.0+dfsg-1
- 12.2.0+dfsg-1
- 13.1.0+dfsg-1
- 13.1.0+dfsg-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://bugzilla.redhat.com/show_bug.cgi?id=1975767
- https://github.com/ansible/ansible/blob/stable-2.9/changelogs/CHANGELOG-v2.9.rst#security-fixes
- https://github.com/ansible/ansible/commit/fe28767970c8ec62aabe493c46b53a5de1e5fac0
- https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-3620