p PatchFirst

CVE-2021-3737

CVE-2021-3737

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A flaw was found in python. An improperly handled HTTP response in the HTTP client code of python may allow a remote attacker, who controls the HTTP server, to make the client script enter an infinite loop, consuming CPU time. The highest threat from this vulnerability is to system availability.

CVSS 7.5 · Alta · EPSS 13,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • python

    Versiones
    • Fixed in python v3.6.14, python v3.7.11, python v3.8.11, python v3.9.6, python v3.10.0b2: Afectada

    Sin corrección publicada

  • pypy3 Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.3.8+dfsg-1

    Actualiza a 7.3.8+dfsg-1

  • pypy3 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.3.8+dfsg-1

    Actualiza a 7.3.8+dfsg-1

  • pypy3 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.3.8+dfsg-1

    Actualiza a 7.3.8+dfsg-1

  • python3.4 Ubuntu:Pro:14.04:LTS

    Versiones
    • 3.4~b1-0ubuntu3
    • 3.4~b1-4ubuntu4
    • 3.4~b1-4ubuntu6
    • 3.4~b1-5ubuntu2
    • 3.4~b2-1
    • 3.4~b3-1ubuntu1
    • 3.4~rc1-1build1
    • 3.4~rc2-1
    • 3.4~rc3-0ubuntu1
    • 3.4.0-1
    • 3.4.0-2ubuntu1
    • 3.4.0-2ubuntu1.1
    • 3.4.3-1ubuntu1~14.04.1
    • 3.4.3-1ubuntu1~14.04.3
    • 3.4.3-1ubuntu1~14.04.4
    • 3.4.3-1ubuntu1~14.04.5
    • 3.4.3-1ubuntu1~14.04.6
    • 3.4.3-1ubuntu1~14.04.7
    • 3.4.3-1ubuntu1~14.04.7+esm2
    • 3.4.3-1ubuntu1~14.04.7+esm4
    • 3.4.3-1ubuntu1~14.04.7+esm6
    • 3.4.3-1ubuntu1~14.04.7+esm7
    • 3.4.3-1ubuntu1~14.04.7+esm8
    • 3.4.3-1ubuntu1~14.04.7+esm10
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.4.3-1ubuntu1~14.04.7+esm11

    Actualiza a 3.4.3-1ubuntu1~14.04.7+esm11

  • python3.5 Ubuntu:Pro:14.04:LTS

    Versiones
    • 3.5.2-2ubuntu0~16.04.4~14.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.5.2-2ubuntu0~16.04.4~14.04.1+esm1

    Actualiza a 3.5.2-2ubuntu0~16.04.4~14.04.1+esm1

  • python3.5 Ubuntu:Pro:16.04:LTS

    Versiones
    • 3.5.0-3
    • 3.5.0-3ubuntu1
    • 3.5.1~rc1-2ubuntu1
    • 3.5.1-1
    • 3.5.1-2
    • 3.5.1-3
    • 3.5.1-5
    • 3.5.1-6ubuntu1
    • 3.5.1-6ubuntu2
    • 3.5.1-9ubuntu1
    • 3.5.1-10
    • 3.5.2-2~16.01
    • 3.5.2-2~16.04
    • 3.5.2-2ubuntu0~16.04.1
    • 3.5.2-2ubuntu0~16.04.2
    • 3.5.2-2ubuntu0~16.04.3
    • 3.5.2-2ubuntu0~16.04.4
    • 3.5.2-2ubuntu0~16.04.5
    • 3.5.2-2ubuntu0~16.04.8
    • 3.5.2-2ubuntu0~16.04.9
    • 3.5.2-2ubuntu0~16.04.10
    • 3.5.2-2ubuntu0~16.04.11
    • 3.5.2-2ubuntu0~16.04.12
    • 3.5.2-2ubuntu0~16.04.13
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.5.2-2ubuntu0~16.04.13+esm1

    Actualiza a 3.5.2-2ubuntu0~16.04.13+esm1

  • python3.6 Ubuntu:18.04:LTS

    Versiones
    • 3.6.3-1ubuntu1
    • 3.6.4~rc1-1
    • 3.6.4~rc1-2
    • 3.6.4-1
    • 3.6.4-2
    • 3.6.4-3build1
    • 3.6.4-4
    • 3.6.5~rc1-1
    • 3.6.5-3
    • 3.6.6-1~18.04
    • 3.6.7-1~18.04
    • 3.6.8-1~18.04.1
    • 3.6.8-1~18.04.2
    • 3.6.8-1~18.04.3
    • 3.6.9-1~18.04
    • 3.6.9-1~18.04ubuntu1
    • 3.6.9-1~18.04ubuntu1.1
    • 3.6.9-1~18.04ubuntu1.3
    • 3.6.9-1~18.04ubuntu1.4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.6.9-1~18.04ubuntu1.6

    Actualiza a 3.6.9-1~18.04ubuntu1.6

  • python3.7 Ubuntu:18.04:LTS

    Versiones
    • 3.7.0~a2-1
    • 3.7.0~a3-1
    • 3.7.0~a3-2
    • 3.7.0~a3-3
    • 3.7.0~a4-1
    • 3.7.0~b1-1
    • 3.7.0~b1-1build1
    • 3.7.0~b2-1
    • 3.7.0~b3-1
    • 3.7.0-1~18.04
    • 3.7.1-1~18.04
    • 3.7.3-2~18.04.1
    • 3.7.5-2~18.04
    • 3.7.5-2~18.04.4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.7.5-2ubuntu1~18.04.2

    Actualiza a 3.7.5-2ubuntu1~18.04.2

  • python3.8 Ubuntu:18.04:LTS

    Versiones
    • 3.8.0-3~18.04
    • 3.8.0-3~18.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.8.0-3ubuntu1~18.04.2

    Actualiza a 3.8.0-3ubuntu1~18.04.2

  • python3.8 Ubuntu:20.04:LTS

    Versiones
    • 3.8.0-1
    • 3.8.0-2
    • 3.8.0-3
    • 3.8.0-4
    • 3.8.0-5
    • 3.8.1-2ubuntu3
    • 3.8.2~rc1-1ubuntu1
    • 3.8.2-1
    • 3.8.2-1ubuntu1
    • 3.8.2-1ubuntu1.1
    • 3.8.2-1ubuntu1.2
    • 3.8.5-1~20.04
    • 3.8.5-1~20.04.2
    • 3.8.5-1~20.04.3
    • 3.8.10-0ubuntu1~20.04
    • 3.8.10-0ubuntu1~20.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.8.10-0ubuntu1~20.04.2

    Actualiza a 3.8.10-0ubuntu1~20.04.2

  • python3.9 Ubuntu:20.04:LTS

    Versiones
    • 3.9.0~rc1-1~20.04
    • 3.9.0-5~20.04
    • 3.9.5-3~20.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.9.5-3ubuntu0~20.04.1

    Actualiza a 3.9.5-3ubuntu0~20.04.1

Fuentes originales

Comprueba tu servidor →