p PatchFirst

CVE-2021-39135

CVE-2021-39135 · UNIX Symbolic Link (Symlink) Following in @npmcli/arborist

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

`@npmcli/arborist`, the library that calculates dependency trees and manages the node_modules folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is accomplished by extracting package contents into a project's `node_modules` folder. If the `node_modules` folder of the root project or any of its dependencies is somehow replaced with a symbolic link, it could allow Arborist to write package dependencies to any arbitrary location on the file system. Note that symbolic links contained within package artifact contents are filtered out, so another means of creating a `node_modules` symbolic link would have to be employed. 1. A `preinstall` script could replace `node_modules` with a symlink. (This is prevented by using `--ignore-scripts`.) 2. An attacker could supply the target with a git repository, instructing them to run `npm install --ignore-scripts` in the root. This may be successful, because `npm install --ignore-scripts` is typically not capable of making changes outside of the project directory, so it may be deemed safe. This is patched in @npmcli/arborist 2.8.2 which is included in npm v7.20.7 and above. For more information including workarounds please see the referenced GHSA-gmw6-94gg-2rc2.

CVSS 8.2 · Alta · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • arborist

    Versiones
    • < 2.8.2: Afectada

    Sin corrección publicada

  • npm Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.24.0+ds-2

    Actualiza a 7.24.0+ds-2

  • npm Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.24.0+ds-2

    Actualiza a 7.24.0+ds-2

  • npm Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.24.0+ds-2

    Actualiza a 7.24.0+ds-2

  • @npmcli/arborist npm

    Intervalos de versiones afectados
    • SEMVER: < 2.8.2

    Actualiza a 2.8.2

  • npm Ubuntu:14.04:LTS

    Versiones
    • 1.2.18~dfsg-3
    • 1.3.10~dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • npm Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.4.21+ds-2
    • 3.5.2-0ubuntu4
    • 3.5.2-0ubuntu4.1.16.04.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • npm Ubuntu:Pro:18.04:LTS

    Versiones
    • 3.5.2-0ubuntu4
    • 3.5.2-0ubuntu4.1.18.04.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • npm Ubuntu:20.04:LTS

    Versiones
    • 5.8.0+ds6-4
    • 6.14.4+ds-1ubuntu2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →