CVE-2021-41089
CVE-2021-41089 · `docker cp` allows unexpected chmod of host files
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Moby is an open-source project created by Docker to enable software containerization. A bug was found in Moby (Docker Engine) where attempting to copy files using `docker cp` into a specially-crafted container can result in Unix file permission changes for existing files in the host’s filesystem, widening access to others. This bug does not directly allow files to be read, modified, or executed without an additional cooperating process. This bug has been fixed in Moby (Docker Engine) 20.10.9. Users should update to this version as soon as possible. Running containers do not need to be restarted.
CVSS 2.8 · Baja · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · containers
Productos y versiones afectados
docker engine
- Versiones
- < 20.10.9: Afectada
Sin corrección publicada
docker.io Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 20.10.10+dfsg1-1
Actualiza a 20.10.10+dfsg1-1
docker.io Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 20.10.10+dfsg1-1
Actualiza a 20.10.10+dfsg1-1
docker.io Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 20.10.10+dfsg1-1
Actualiza a 20.10.10+dfsg1-1
docker.io Ubuntu:Pro:16.04:LTS
- Versiones
- 1.6.2~dfsg1-1ubuntu4
- 1.10.2-0ubuntu3
- 1.10.2-0ubuntu4
- 1.10.3-0ubuntu1
- 1.10.3-0ubuntu4
- 1.10.3-0ubuntu5
- 1.10.3-0ubuntu6
- 1.11.2-0ubuntu5~16.04
- 1.12.1-0ubuntu13~16.04.1
- 1.12.3-0ubuntu4~16.04.2
- 1.12.6-0ubuntu1~16.04.1
- 1.13.1-0ubuntu1~16.04.2
- 17.03.2-0ubuntu2~16.04.1
- 18.06.1-0ubuntu1~16.04.2
- 18.06.1-0ubuntu1.2~16.04.1
- 18.09.2-0ubuntu1~16.04.1
- 18.09.5-0ubuntu1~16.04.2
- 18.09.7-0ubuntu1~16.04.1
- 18.09.7-0ubuntu1~16.04.4
- 18.09.7-0ubuntu1~16.04.5
- 18.09.7-0ubuntu1~16.04.6
- 18.09.7-0ubuntu1~16.04.7
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.09.7-0ubuntu1~16.04.9+esm1
Actualiza a 18.09.7-0ubuntu1~16.04.9+esm1
docker.io Ubuntu:18.04:LTS
- Versiones
- 1.13.1-0ubuntu6
- 17.03.2-0ubuntu1
- 17.03.2-0ubuntu3
- 17.03.2-0ubuntu5
- 17.12.1-0ubuntu1
- 18.06.1-0ubuntu1~18.04.1
- 18.06.1-0ubuntu1.2~18.04.1
- 18.09.2-0ubuntu1~18.04.1
- 18.09.5-0ubuntu1~18.04.2
- 18.09.7-0ubuntu1~18.04.1
- 18.09.7-0ubuntu1~18.04.3
- 18.09.7-0ubuntu1~18.04.4
- 19.03.6-0ubuntu1~18.04.1
- 19.03.6-0ubuntu1~18.04.2
- 19.03.6-0ubuntu1~18.04.3
- 20.10.2-0ubuntu1~18.04.2
- 20.10.2-0ubuntu1~18.04.3
- 20.10.7-0ubuntu1~18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 20.10.7-0ubuntu1~18.04.2
Actualiza a 20.10.7-0ubuntu1~18.04.2
docker.io Ubuntu:20.04:LTS
- Versiones
- 19.03.2-0ubuntu1
- 19.03.6-0ubuntu1
- 19.03.8-0ubuntu1
- 19.03.8-0ubuntu1.20.04
- 19.03.8-0ubuntu1.20.04.1
- 19.03.8-0ubuntu1.20.04.2
- 20.10.2-0ubuntu1~20.04.2
- 20.10.2-0ubuntu1~20.04.3
- 20.10.7-0ubuntu1~20.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 20.10.7-0ubuntu1~20.04.2
Actualiza a 20.10.7-0ubuntu1~20.04.2
docker.io Ubuntu:22.04:LTS
- Versiones
- 20.10.7-0ubuntu5
- Intervalos de versiones afectados
- ECOSYSTEM: < 20.10.7-0ubuntu7
Actualiza a 20.10.7-0ubuntu7
Fuentes originales
- https://github.com/moby/moby/security/advisories/GHSA-v994-f8vw-g7j4
- https://github.com/moby/moby/commit/bce32e5c93be4caf1a592582155b9cb837fc129a
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZNFADTCHHYWVM6W4NJ6CB4FNFM2VMBIB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B5Q6G6I4W5COQE25QMC7FJY3I3PAYFBB/
- https://cert-portal.siemens.com/productcert/pdf/ssa-222547.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2021-41089