p PatchFirst

CVE-2021-41099

CVE-2021-41099 · Integer overflow issue with strings in Redis

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Redis is an open source, in-memory database that persists on disk. An integer overflow bug in the underlying string library can be used to corrupt the heap and potentially result with denial of service or remote code execution. The vulnerability involves changing the default proto-max-bulk-len configuration parameter to a very large value and constructing specially crafted network payloads or commands. The problem is fixed in Redis versions 6.2.6, 6.0.16 and 5.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from modifying the proto-max-bulk-len configuration parameter. This can be done using ACL to restrict unprivileged users from using the CONFIG SET command.

CVSS 7.5 · Alta · EPSS 3,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · database

Productos y versiones afectados

  • redis

    Versiones
    • < 5.0.14: Afectada
    • >= 6.0.0, < 6.0.16: Afectada
    • >= 6.2.0, 6.2.6: Afectada

    Sin corrección publicada

  • redis Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5:6.0.16-1

    Actualiza a 5:6.0.16-1

  • redis Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5:6.0.16-1

    Actualiza a 5:6.0.16-1

  • redis Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5:6.0.16-1

    Actualiza a 5:6.0.16-1

  • redis Ubuntu:Pro:18.04:LTS

    Versiones
    • 4:4.0.1-7
    • 4:4.0.2-6
    • 4:4.0.2-9
    • 5:4.0.5-1
    • 5:4.0.6-1
    • 5:4.0.6-2
    • 5:4.0.7-1
    • 5:4.0.8-1
    • 5:4.0.8-2
    • 5:4.0.9-1
    • 5:4.0.9-1ubuntu0.1
    • 5:4.0.9-1ubuntu0.2
    • 5:4.0.9-1ubuntu0.2+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm3

    Actualiza a 5:4.0.9-1ubuntu0.2+esm3

  • redis Ubuntu:Pro:20.04:LTS

    Versiones
    • 5:5.0.5-2build1
    • 5:5.0.6-1
    • 5:5.0.7-1
    • 5:5.0.7-2
    • 5:5.0.7-2ubuntu0.1~esm1
    • 5:5.0.7-2ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm1

    Actualiza a 5:5.0.7-2ubuntu0.1+esm1

Fuentes originales

Comprueba tu servidor →