CVE-2021-41281
CVE-2021-41281 · Path traversal in Matrix Synapse
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Synapse is a package for Matrix homeservers written in Python 3/Twisted. Prior to version 1.47.1, Synapse instances with the media repository enabled can be tricked into downloading a file from a remote server into an arbitrary directory. No authentication is required for the affected endpoint. The last 2 directories and file name of the path are chosen randomly by Synapse and cannot be controlled by an attacker, which limits the impact. Homeservers with the media repository disabled are unaffected. Homeservers with a federation whitelist are also unaffected, since Synapse will check the remote hostname, including the trailing `../`s, against the whitelist. Server administrators should upgrade to 1.47.1 or later. Server administrators using a reverse proxy could, at the expense of losing media functionality, may block the certain endpoints as a workaround. Alternatively, non-containerized deployments can be adapted to use the hardened systemd config.
CVSS 7.5 · Alta · EPSS 1,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
synapse
- Versiones
- < 1.47.1: Afectada
Sin corrección publicada
matrix-synapse PyPI
- Versiones
- 0.33.5
- 0.33.5.1
- 0.33.6
- 0.33.6rc1
- 0.33.7
- 0.33.7rc1
- 0.33.7rc2
- 0.33.8
- 0.33.8rc2
- 0.33.9
- 0.34.0
- 0.34.0.1
- 0.34.0rc1
- 0.34.0rc2
- 0.34.1.1
- 0.99.0
- 0.99.0rc1
- 0.99.0rc2
- 0.99.0rc3
- 0.99.0rc4
- 0.99.1
- 0.99.1.1
- 0.99.1rc1
- 0.99.1rc2
- 0.99.2
- 0.99.2rc1
- 0.99.3
- 0.99.3.1
- 0.99.3.2
- 0.99.3rc1
- 0.99.4
- 0.99.4rc1
- 0.99.5
- 0.99.5.1
- 0.99.5.2
- 0.99.5rc1
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.0rc3
- 1.1.0
- 1.1.0rc1
- 1.1.0rc2
- 1.10.0
- 1.10.0rc1
- 1.10.0rc2
- 1.10.0rc3
- 1.10.0rc5
- 1.10.1
- 1.11.0
- 1.11.0rc1
- 1.11.1
- 1.12.0
- 1.12.0rc1
- 1.12.1
- 1.12.1rc1
- 1.12.2
- 1.12.3
- 1.12.4
- 1.12.4rc1
- 1.13.0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.0rc3
- 1.14.0
- 1.14.0rc1
- 1.14.0rc2
- 1.15.0
- 1.15.0rc1
- 1.15.1
- 1.15.2
- 1.16.0
- 1.16.0rc1
- 1.16.0rc2
- 1.16.1
- 1.17.0
- 1.17.0rc1
- 1.18.0
- 1.18.0rc1
- 1.18.0rc2
- 1.19.0
- 1.19.0rc1
- 1.19.1
- 1.19.1rc1
- 1.19.2
- 1.19.3
- 1.2.0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.20.0
- 1.20.0rc1
- 1.20.0rc2
- 1.20.0rc3
- 1.20.0rc4
- 1.20.0rc5
- 1.20.1
- 1.21.0
- 1.21.0rc1
- 1.21.0rc2
- 1.21.0rc3
- 1.21.1
- 1.21.2
- 1.22.0
- 1.22.0rc1
- 1.22.0rc2
- 1.22.1
- 1.23.0
- 1.23.0rc1
- 1.23.1
- 1.24.0
- 1.24.0rc1
- 1.24.0rc2
- 1.25.0
- 1.25.0rc1
- 1.26.0
- 1.26.0rc1
- 1.26.0rc2
- 1.27.0
- 1.27.0rc1
- 1.27.0rc2
- 1.28.0
- 1.28.0rc1
- 1.29.0
- 1.29.0rc1
- 1.3.0
- 1.3.0rc1
- 1.3.1
- 1.30.0
- 1.30.0rc1
- 1.30.1
- 1.31.0
- 1.31.0rc1
- 1.32.0
- 1.32.0rc1
- 1.32.1
- 1.32.2
- 1.33.0
- 1.33.0rc1
- 1.33.0rc2
- 1.33.1
- 1.33.2
- 1.34.0
- 1.34.0rc1
- 1.35.0
- 1.35.0rc1
- 1.35.0rc2
- 1.35.0rc3
- 1.35.1
- 1.36.0
- 1.36.0rc1
- 1.36.0rc2
- 1.37.0
- 1.37.0rc1
- 1.37.1
- 1.37.1rc1
- 1.38.0
- 1.38.0rc1
- 1.38.0rc2
- 1.38.0rc3
- 1.38.1
- 1.39.0
- 1.39.0rc1
- 1.39.0rc2
- 1.39.0rc3
- 1.4.0
- 1.4.0rc1
- 1.4.0rc2
- 1.4.1
- 1.4.1rc1
- 1.40.0
- 1.40.0rc1
- 1.40.0rc2
- 1.40.0rc3
- 1.41.0
- 1.41.0rc1
- 1.41.1
- 1.42.0
- 1.42.0rc1
- 1.42.0rc2
- 1.43.0
- 1.43.0rc1
- 1.43.0rc2
- 1.44.0
- 1.44.0rc1
- 1.44.0rc2
- 1.44.0rc3
- 1.45.0
- 1.45.0rc1
- 1.45.0rc2
- 1.45.1
- 1.46.0
- 1.46.0rc1
- 1.47.0
- 1.47.0rc1
- 1.47.0rc2
- 1.47.0rc3
- 1.5.0
- 1.5.0rc1
- 1.5.0rc2
- 1.5.1
- 1.6.0
- 1.6.0rc1
- 1.6.0rc2
- 1.6.1
- 1.7.0
- 1.7.0rc1
- 1.7.0rc2
- 1.7.1
- 1.7.2
- 1.7.3
- 1.8.0
- 1.8.0rc1
- 1.9.0
- 1.9.0.dev1
- 1.9.0.dev2
- 1.9.0rc1
- 1.9.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.47.1
Actualiza a 1.47.1
matrix-synapse PyPI
- Versiones
- 0.33.5
- 0.33.5.1
- 0.33.6
- 0.33.6rc1
- 0.33.7
- 0.33.7rc1
- 0.33.7rc2
- 0.33.8
- 0.33.8rc2
- 0.33.9
- 0.34.0
- 0.34.0.1
- 0.34.0rc1
- 0.34.0rc2
- 0.34.1.1
- 0.99.0
- 0.99.0rc1
- 0.99.0rc2
- 0.99.0rc3
- 0.99.0rc4
- 0.99.1
- 0.99.1.1
- 0.99.1rc1
- 0.99.1rc2
- 0.99.2
- 0.99.2rc1
- 0.99.3
- 0.99.3.1
- 0.99.3.2
- 0.99.3rc1
- 0.99.4
- 0.99.4rc1
- 0.99.5
- 0.99.5.1
- 0.99.5.2
- 0.99.5rc1
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.0rc3
- 1.1.0
- 1.1.0rc1
- 1.1.0rc2
- 1.10.0
- 1.10.0rc1
- 1.10.0rc2
- 1.10.0rc3
- 1.10.0rc5
- 1.10.1
- 1.11.0
- 1.11.0rc1
- 1.11.1
- 1.12.0
- 1.12.0rc1
- 1.12.1
- 1.12.1rc1
- 1.12.2
- 1.12.3
- 1.12.4
- 1.12.4rc1
- 1.13.0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.0rc3
- 1.14.0
- 1.14.0rc1
- 1.14.0rc2
- 1.15.0
- 1.15.0rc1
- 1.15.1
- 1.15.2
- 1.16.0
- 1.16.0rc1
- 1.16.0rc2
- 1.16.1
- 1.17.0
- 1.17.0rc1
- 1.18.0
- 1.18.0rc1
- 1.18.0rc2
- 1.19.0
- 1.19.0rc1
- 1.19.1
- 1.19.1rc1
- 1.19.2
- 1.19.3
- 1.2.0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.20.0
- 1.20.0rc1
- 1.20.0rc2
- 1.20.0rc3
- 1.20.0rc4
- 1.20.0rc5
- 1.20.1
- 1.21.0
- 1.21.0rc1
- 1.21.0rc2
- 1.21.0rc3
- 1.21.1
- 1.21.2
- 1.22.0
- 1.22.0rc1
- 1.22.0rc2
- 1.22.1
- 1.23.0
- 1.23.0rc1
- 1.23.1
- 1.24.0
- 1.24.0rc1
- 1.24.0rc2
- 1.25.0
- 1.25.0rc1
- 1.26.0
- 1.26.0rc1
- 1.26.0rc2
- 1.27.0
- 1.27.0rc1
- 1.27.0rc2
- 1.28.0
- 1.28.0rc1
- 1.29.0
- 1.29.0rc1
- 1.3.0
- 1.3.0rc1
- 1.3.1
- 1.30.0
- 1.30.0rc1
- 1.30.1
- 1.31.0
- 1.31.0rc1
- 1.32.0
- 1.32.0rc1
- 1.32.1
- 1.32.2
- 1.33.0
- 1.33.0rc1
- 1.33.0rc2
- 1.33.1
- 1.33.2
- 1.34.0
- 1.34.0rc1
- 1.35.0
- 1.35.0rc1
- 1.35.0rc2
- 1.35.0rc3
- 1.35.1
- 1.36.0
- 1.36.0rc1
- 1.36.0rc2
- 1.37.0
- 1.37.0rc1
- 1.37.1
- 1.37.1rc1
- 1.38.0
- 1.38.0rc1
- 1.38.0rc2
- 1.38.0rc3
- 1.38.1
- 1.39.0
- 1.39.0rc1
- 1.39.0rc2
- 1.39.0rc3
- 1.4.0
- 1.4.0rc1
- 1.4.0rc2
- 1.4.1
- 1.4.1rc1
- 1.40.0
- 1.40.0rc1
- 1.40.0rc2
- 1.40.0rc3
- 1.41.0
- 1.41.0rc1
- 1.41.1
- 1.42.0
- 1.42.0rc1
- 1.42.0rc2
- 1.43.0
- 1.43.0rc1
- 1.43.0rc2
- 1.44.0
- 1.44.0rc1
- 1.44.0rc2
- 1.44.0rc3
- 1.45.0
- 1.45.0rc1
- 1.45.0rc2
- 1.45.1
- 1.46.0
- 1.46.0rc1
- 1.47.0
- 1.47.0rc1
- 1.47.0rc2
- 1.47.0rc3
- 1.5.0
- 1.5.0rc1
- 1.5.0rc2
- 1.5.1
- 1.6.0
- 1.6.0rc1
- 1.6.0rc2
- 1.6.1
- 1.7.0
- 1.7.0rc1
- 1.7.0rc2
- 1.7.1
- 1.7.2
- 1.7.3
- 1.8.0
- 1.8.0rc1
- 1.9.0
- 1.9.0.dev1
- 1.9.0.dev2
- 1.9.0rc1
- 1.9.1
- Intervalos de versiones afectados
- GIT: < 91f2bd0907f1d05af67166846988e49644eb650c
- ECOSYSTEM: < 1.47.1
Actualiza a 1.47.1
matrix-synapse Ubuntu:Pro:18.04:LTS
- Versiones
- 0.19.2+dfsg-6
- 0.24.0+dfsg-1
- 0.24.0+dfsg-1ubuntu0.1~esm1
- 0.24.0+dfsg-1ubuntu0.1~esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
matrix-synapse Ubuntu:Pro:20.04:LTS
- Versiones
- 1.3.0-1
- 1.4.0-1
- 1.5.0-1
- 1.5.1-1
- 1.6.0-1
- 1.6.1-1
- 1.7.0-2
- 1.7.1-1
- 1.7.2-1
- 1.7.3-1
- 1.8.0-1
- 1.9.0-1
- 1.9.1-1
- 1.10.0-1
- 1.10.0-2
- 1.11.0-1
- 1.11.0-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
matrix-synapse Ubuntu:Pro:22.04:LTS
- Versiones
- 1.39.0-1
- 1.47.0-2
- 1.47.1-1
- 1.48.0-1
- 1.49.0-1
- 1.49.2-1
- 1.50.1-1
- 1.50.2-1
- 1.51.0-1
- 1.52.0-1
- 1.53.0-1
- 1.53.0-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/matrix-org/synapse/security/advisories/GHSA-3hfw-x7gx-437c
- https://github.com/matrix-org/synapse/commit/91f2bd090
- https://github.com/matrix-org/synapse/releases/tag/v1.47.1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N3WY56LCEZ4ZECLWV5KMAXF2PSMUB4F2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/EU7QRE55U4IUEDLKT5IYPWL3UXMELFAS/
- https://nvd.nist.gov/vuln/detail/CVE-2021-41281