p PatchFirst

CVE-2021-43835

CVE-2021-43835 · Privilege escalation in the Sulu Admin panel

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Sulu is an open-source PHP content management system based on the Symfony framework. In affected versions Sulu users who have access to any subset of the admin UI are able to elevate their privilege. Over the API it was possible for them to give themselves permissions to areas which they did not already had. This issue was introduced in 2.0.0-RC1 with the new ProfileController putAction. The versions have been patched in 2.2.18, 2.3.8 and 2.4.0. For users unable to upgrade the only known workaround is to apply a patch to the ProfileController manually.

CVSS 7.2 · Alta · EPSS 1,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • sulu

    Versiones
    • >= 2.0.0, < 2.2.18: Afectada
    • >= 2.3.0, < 2.3.8: Afectada

    Sin corrección publicada

  • sulu/sulu Packagist

    Versiones
    • 2.0.0
    • 2.0.1
    • 2.0.10
    • 2.0.11
    • 2.0.12
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.0.6
    • 2.0.7
    • 2.0.8
    • 2.0.9
    • 2.1.0
    • 2.1.0-RC1
    • 2.1.0-RC2
    • 2.1.1
    • 2.1.10
    • 2.1.11
    • 2.1.12
    • 2.1.13
    • 2.1.14
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    • 2.1.7
    • 2.1.8
    • 2.1.9
    • 2.2.0
    • 2.2.0-RC1
    • 2.2.1
    • 2.2.10
    • 2.2.11
    • 2.2.12
    • 2.2.13
    • 2.2.14
    • 2.2.15
    • 2.2.16
    • 2.2.17
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.2.8
    • 2.2.9
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.0.0, < 2.2.18

    Actualiza a 2.2.18

  • sulu/sulu Packagist

    Versiones
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 2.3.6
    • 2.3.7
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.8

    Actualiza a 2.3.8

  • sulu/sulu Packagist

    Versiones
    • 2.4.0-RC1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.4.0-RC1, < 2.4.0

    Actualiza a 2.4.0

Fuentes originales

Comprueba tu servidor →