CVE-2021-45079
CVE-2021-45079
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In strongSwan before 5.9.5, a malicious responder can send an EAP-Success message too early without actually authenticating the client and (in the case of EAP methods with mutual authentication and EAP-only authentication for IKEv2) even without server authentication.
CVSS 9.1 · Crítica · EPSS 2,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
strongswan Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.9.5-1
Actualiza a 5.9.5-1
strongswan Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.9.5-1
Actualiza a 5.9.5-1
strongswan Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.9.5-1
Actualiza a 5.9.5-1
strongswan Ubuntu:Pro:14.04:LTS
- Versiones
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- 5.1.2-0ubuntu2.2
- 5.1.2-0ubuntu2.3
- 5.1.2-0ubuntu2.4
- 5.1.2-0ubuntu2.5
- 5.1.2-0ubuntu2.6
- 5.1.2-0ubuntu2.7
- 5.1.2-0ubuntu2.8
- 5.1.2-0ubuntu2.10
- 5.1.2-0ubuntu2.11
- 5.1.2-0ubuntu2.11+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.1.2-0ubuntu2.11+esm2
Actualiza a 5.1.2-0ubuntu2.11+esm2
strongswan Ubuntu:Pro:16.04:LTS
- Versiones
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- 5.3.5-1ubuntu3.4
- 5.3.5-1ubuntu3.5
- 5.3.5-1ubuntu3.7
- 5.3.5-1ubuntu3.8
- 5.3.5-1ubuntu3.8+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.3.5-1ubuntu3.8+esm2
Actualiza a 5.3.5-1ubuntu3.8+esm2
strongswan Ubuntu:Pro:FIPS-updates:16.04:LTS
- Versiones
- 5.3.5-1ubuntu3.fips.3.4.1
- 5.3.5-1ubuntu3.fips.3.4.2
- 5.3.5-1ubuntu3.fips.3.8.1
- 5.3.5-1ubuntu3.fips.3.8.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.3.5-1ubuntu3.fips.3.8.3
Actualiza a 5.3.5-1ubuntu3.fips.3.8.3
strongswan Ubuntu:Pro:FIPS:16.04:LTS
- Versiones
- 5.3.5-1ubuntu3.fips.3.1
- 5.3.5-1ubuntu3.fips.3.2
- 5.3.5-1ubuntu3.fips.3.3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
strongswan Ubuntu:18.04:LTS
- Versiones
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- 5.6.2-1ubuntu2.3
- 5.6.2-1ubuntu2.4
- 5.6.2-1ubuntu2.5
- 5.6.2-1ubuntu2.6
- 5.6.2-1ubuntu2.7
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.6.2-1ubuntu2.8
Actualiza a 5.6.2-1ubuntu2.8
strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS
- Versiones
- 5.6.2-1ubuntu2.fips.2.5.1
- 5.6.2-1ubuntu2.fips.2.7.1
- 5.6.2-1ubuntu2.fips.2.7.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.6.2-1ubuntu2.fips.2.8.1
Actualiza a 5.6.2-1ubuntu2.fips.2.8.1
strongswan Ubuntu:Pro:FIPS:18.04:LTS
- Versiones
- 5.6.2-1ubuntu2.fips.2.4.2
- 5.6.2-1ubuntu2.fips.2.5.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
strongswan Ubuntu:20.04:LTS
- Versiones
- 5.7.2-1ubuntu3
- 5.8.1-1ubuntu1
- 5.8.2-1ubuntu1
- 5.8.2-1ubuntu2
- 5.8.2-1ubuntu3
- 5.8.2-1ubuntu3.1
- 5.8.2-1ubuntu3.2
- 5.8.2-1ubuntu3.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.8.2-1ubuntu3.4
Actualiza a 5.8.2-1ubuntu3.4
strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS
- Versiones
- 5.8.2-1ubuntu3.fips.3.1.2
- 5.8.2-1ubuntu3.fips.3.3.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.8.2-1ubuntu3.fips.3.4.1
Actualiza a 5.8.2-1ubuntu3.fips.3.4.1
strongswan Ubuntu:Pro:FIPS:20.04:LTS
- Versiones
- 5.8.2-1ubuntu3.fips.3.1.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
strongswan Ubuntu:22.04:LTS
- Versiones
- 5.9.1-1ubuntu3
- 5.9.1-1ubuntu3.1
- 5.9.4-1ubuntu1
- 5.9.4-1ubuntu2
- 5.9.4-1ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.9.4-1ubuntu4
Actualiza a 5.9.4-1ubuntu4