p PatchFirst

CVE-2022-23471

CVE-2022-23471 · containerd CRI stream server: Host memory exhaustion through terminal resize goroutine leak

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

containerd is an open source container runtime. A bug was found in containerd's CRI implementation where a user can exhaust memory on the host. In the CRI stream server, a goroutine is launched to handle terminal resize events if a TTY is requested. If the user's process fails to launch due to, for example, a faulty command, the goroutine will be stuck waiting to send without a receiver, resulting in a memory leak. Kubernetes and crictl can both be configured to use containerd's CRI implementation and the stream server is used for handling container IO. This bug has been fixed in containerd 1.6.12 and 1.5.16. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used and that only trusted users have permissions to execute commands in running containers.

CVSS 5.7 · Media · EPSS 1,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · containers

Productos y versiones afectados

  • containerd

    Versiones
    • < 1.5.16: Afectada
    • >= 1.6.0, < 1.6.12: Afectada

    Sin corrección publicada

  • containerd Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.12~ds1-1

    Actualiza a 1.6.12~ds1-1

  • containerd Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.12~ds1-1

    Actualiza a 1.6.12~ds1-1

  • containerd Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.12~ds1-1

    Actualiza a 1.6.12~ds1-1

  • containerd Ubuntu:Pro:16.04:LTS

    Versiones
    • 0.2.1-0ubuntu4~16.04
    • 0.2.3-0ubuntu1~16.04
    • 0.2.5-0ubuntu1~16.04.1
    • 1.2.6-0ubuntu1~16.04.2
    • 1.2.6-0ubuntu1~16.04.3
    • 1.2.6-0ubuntu1~16.04.4
    • 1.2.6-0ubuntu1~16.04.5
    • 1.2.6-0ubuntu1~16.04.6
    • 1.2.6-0ubuntu1~16.04.6+esm1
    • 1.2.6-0ubuntu1~16.04.6+esm2
    • 1.2.6-0ubuntu1~16.04.6+esm4
    • 1.2.6-0ubuntu1~16.04.6+esm5
    • 1.2.6-0ubuntu1~16.04.6+esm6
    • 1.2.6-0ubuntu1~16.04.6+esm7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • containerd Ubuntu:18.04:LTS

    Versiones
    • 0.2.5-0ubuntu2
    • 1.2.6-0ubuntu1~18.04.1
    • 1.2.6-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.1
    • 1.3.3-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.3
    • 1.3.3-0ubuntu1~18.04.4
    • 1.4.4-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.1
    • 1.5.2-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.3
    • 1.5.5-0ubuntu3~18.04.1
    • 1.5.5-0ubuntu3~18.04.2
    • 1.5.9-0ubuntu1~18.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.9-0ubuntu1~18.04.2

    Actualiza a 1.5.9-0ubuntu1~18.04.2

  • containerd Ubuntu:20.04:LTS

    Versiones
    • 1.2.10-0ubuntu1
    • 1.3.2-0ubuntu1
    • 1.3.3-0ubuntu1
    • 1.3.3-0ubuntu2
    • 1.3.3-0ubuntu2.1
    • 1.3.3-0ubuntu2.2
    • 1.3.3-0ubuntu2.3
    • 1.4.4-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.1
    • 1.5.2-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.3
    • 1.5.5-0ubuntu3~20.04.1
    • 1.5.5-0ubuntu3~20.04.2
    • 1.5.9-0ubuntu1~20.04.1
    • 1.5.9-0ubuntu1~20.04.4
    • 1.5.9-0ubuntu1~20.04.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.9-0ubuntu1~20.04.6

    Actualiza a 1.5.9-0ubuntu1~20.04.6

  • containerd Ubuntu:22.04:LTS

    Versiones
    • 1.5.5-0ubuntu3
    • 1.5.9-0ubuntu1
    • 1.5.9-0ubuntu2
    • 1.5.9-0ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.9-0ubuntu3.1

    Actualiza a 1.5.9-0ubuntu3.1

Fuentes originales

Comprueba tu servidor →