p PatchFirst

CVE-2022-23485

CVE-2022-23485 · Invite code reuse via cookie manipulation in sentry

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Sentry is an error tracking and performance monitoring platform. In versions of the sentry python library prior to 22.11.0 an attacker with a known valid invite link could manipulate a cookie to allow the same invite link to be reused on multiple accounts when joining an organization. As a result an attacker with a valid invite link can create multiple users and join an organization they may not have been originally invited to. This issue was patched in version 22.11.0. Sentry SaaS customers do not need to take action. Self-hosted Sentry installs on systems which can not upgrade can disable the invite functionality until they are ready to deploy the patched version by editing their `sentry.conf.py` file (usually located at `~/.sentry/`).

CVSS 6.4 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • sentry

    Versiones
    • >= 20.6.0, < 22.11.0: Afectada

    Sin corrección publicada

  • sentry PyPI

    Versiones
    • 20.10.1
    • 20.11.0
    • 20.11.1
    • 20.12.0
    • 20.12.1
    • 20.6.0
    • 20.7.0
    • 20.7.1
    • 20.7.2
    • 20.8.0
    • 21.1.0
    • 21.10.0
    • 21.11.0
    • 21.12.0
    • 21.2.0
    • 21.3.0
    • 21.3.1
    • 21.4.0
    • 21.4.1
    • 21.5.0
    • 21.5.1
    • 21.6.0
    • 21.6.1
    • 21.6.2
    • 21.6.3
    • 21.7.0
    • 21.8.0
    • 21.9.0
    • 22.1.0
    • 22.10.0
    • 22.2.0
    • 22.3.0
    • 22.4.0
    • 22.5.0
    • 22.6.0
    • 22.7.0
    • 22.8.0
    • 22.9.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 20.6.0, < 22.11.0

    Actualiza a 22.11.0

  • sentry-python Ubuntu:20.04:LTS

    Versiones
    • 0.12.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • sentry-python Ubuntu:22.04:LTS

    Versiones
    • 0.13.2-1
    • 1.4.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • sentry-python Ubuntu:24.04:LTS

    Versiones
    • 1.9.10-2
    • 1.39.2-0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • sentry-python Ubuntu:25.10

    Versiones
    • 2.18.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • sentry-python Ubuntu:26.10

    Versiones
    • 2.22.0-1
    • 2.60.0-3
    • 2.63.0-1
    • 2.64.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • sentry-python Ubuntu:26.04:LTS

    Versiones
    • 2.18.0-1
    • 2.22.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →