CVE-2022-24752
CVE-2022-24752 · SQL Injection through sorting parameters in SyliusGridBundle
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
SyliusGridBundle is a package of generic data grids for Symfony applications. Prior to versions 1.10.1 and 1.11-rc2, values added at the end of query sorting were passed directly to the database. The maintainers do not know if this could lead to direct SQL injections but took steps to remediate the vulnerability. The issue is fixed in versions 1.10.1 and 1.11-rc2. As a workaround, overwrite the`Sylius\Component\Grid\Sorting\Sorter.php` class and register it in the container. More information about this workaround is available in the GitHub Security Advisory.
CVSS 9.8 · Crítica · EPSS 1,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
syliusgridbundle
- Versiones
- < 1.10.1: Afectada
- 1.11-alpha, <= 1.11-rc: Afectada
Sin corrección publicada
sylius/grid-bundle Packagist
- Versiones
- 1.0.0-patch1
- 1.2.4-patch1
- 1.4.0-patch1
- v1.0.0
- v1.0.0-alpha.1
- v1.0.0-alpha.2
- v1.0.0-beta.1
- v1.0.0-beta.2
- v1.0.0-beta.3
- v1.0.0-rc.1
- v1.0.0-rc.2
- v1.0.1
- v1.0.10
- v1.0.11
- v1.0.12
- v1.0.13
- v1.0.14
- v1.0.15
- v1.0.16
- v1.0.17
- v1.0.18
- v1.0.2
- v1.0.3
- v1.0.4
- v1.0.5
- v1.0.6
- v1.0.7
- v1.0.8
- v1.0.9
- v1.1.0
- v1.1.0-RC
- v1.1.1
- v1.1.10
- v1.1.11
- v1.1.12
- v1.1.13
- v1.1.14
- v1.1.15
- v1.1.17
- v1.1.18
- v1.1.19
- v1.1.2
- v1.1.3
- v1.1.4
- v1.1.5
- v1.1.6
- v1.1.7
- v1.1.8
- v1.1.9
- v1.10.0
- v1.2.0
- v1.2.0-BETA
- v1.2.0-RC
- v1.2.1
- v1.2.10
- v1.2.11
- v1.2.12
- v1.2.13
- v1.2.14
- v1.2.15
- v1.2.16
- v1.2.17
- v1.2.18
- v1.2.2
- v1.2.3
- v1.2.4
- v1.2.5
- v1.2.6
- v1.2.7
- v1.2.8
- v1.2.9
- v1.3.0
- v1.3.0-BETA
- v1.3.1
- v1.3.10
- v1.3.11
- v1.3.12
- v1.3.13
- v1.3.2
- v1.3.3
- v1.3.4
- v1.3.5
- v1.3.6
- v1.3.7
- v1.3.8
- v1.3.9
- v1.4.0
- v1.4.0-BETA.1
- v1.4.1
- v1.4.2
- v1.4.3
- v1.4.4
- v1.4.5
- v1.5.0
- v1.5.1
- v1.6.0
- v1.6.1
- v1.6.2
- v1.6.3
- v1.7.0
- v1.7.1
- v1.7.2
- v1.7.3
- v1.7.4
- v1.7.5
- v1.8.0
- v1.8.0-BETA.1
- v1.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.10.1
Actualiza a 1.10.1
Fuentes originales
- https://github.com/Sylius/SyliusGridBundle/security/advisories/GHSA-2xmm-g482-4439
- https://github.com/Sylius/SyliusGridBundle/pull/222
- https://github.com/Sylius/SyliusGridBundle/commit/73d0791d0575f955e830a3da4c3345f420d2f784
- https://github.com/Sylius/SyliusGridBundle/releases/tag/v1.10.1
- https://github.com/Sylius/SyliusGridBundle/releases/tag/v1.11.0-RC.2
- https://nvd.nist.gov/vuln/detail/CVE-2022-24752