p PatchFirst

CVE-2022-24766

CVE-2022-24766 · Insufficient Protection against HTTP Request Smuggling in mitmproxy

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

mitmproxy is an interactive, SSL/TLS-capable intercepting proxy. In mitmproxy 7.0.4 and below, a malicious client or server is able to perform HTTP request smuggling attacks through mitmproxy. This means that a malicious client/server could smuggle a request/response through mitmproxy as part of another request/response's HTTP message body. While mitmproxy would only see one request, the target server would see multiple requests. A smuggled request is still captured as part of another request's body, but it does not appear in the request list and does not go through the usual mitmproxy event hooks, where users may have implemented custom access control checks or input sanitization. Unless mitmproxy is used to protect an HTTP/1 service, no action is required. The vulnerability has been fixed in mitmproxy 8.0.0 and above. There are currently no known workarounds.

CVSS 9.8 · Crítica · EPSS 1,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • mitmproxy

    Versiones
    • <= 7.0.4: Afectada

    Sin corrección publicada

  • mitmproxy Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 8.1.1-1

    Actualiza a 8.1.1-1

  • mitmproxy Debian:14

    Versiones
    • 0.10-1
    • 0.10-2
    • 0.10.1-1
    • 0.10.1-2
    • 0.11.3-1
    • 0.11.3-2
    • 0.11.3-3
    • 0.12.1-1
    • 0.12.1-2
    • 0.13-1
    • 0.15-1
    • 0.15-2
    • 0.18.1-1
    • 0.18.1-2
    • 0.18.2-1
    • 0.18.2-2
    • 0.18.2-3
    • 0.18.2-4
    • 0.18.2-5
    • 0.18.2-6
    • 0.6-1
    • 0.6-2
    • 0.6-3
    • 0.7-1
    • 0.8-1
    • 0.8-2
    • 0.9.1-1
    • 0.9.1-2
    • 0.9.2-1
    • 0.9.2-2
    • 2.0.2-1
    • 2.0.2-2
    • 2.0.2-3
    • 2.0.2-4
    • 3.0.3-1
    • 3.0.4-1
    • 4.0.4-1
    • 4.0.4-2
    • 4.0.4-3
    • 4.0.4-4
    • 4.0.4-5
    • 4.0.4-6
    • 4.0.4-6.1
    • 5.1.1-1
    • 5.1.1-2
    • 5.3.0-1
    • 5.3.0-2
    • 5.3.0-3
    • 6.0.2-1
    • 6.0.2-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 8.1.1-1

    Actualiza a 8.1.1-1

  • mitmproxy PyPI

    Versiones
    • 0.10
    • 0.10.1
    • 0.11
    • 0.11.1
    • 0.11.2
    • 0.11.3
    • 0.12.0
    • 0.12.1
    • 0.13
    • 0.14.0
    • 0.15
    • 0.16
    • 0.17
    • 0.18.1
    • 0.18.2
    • 0.18.3
    • 0.8
    • 0.8.1
    • 0.9
    • 0.9.1
    • 0.9.2
    • 1.0.0
    • 1.0.1
    • 1.0.2
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 4.0.0
    • 4.0.1
    • 4.0.3
    • 4.0.4
    • 5.0.0
    • 5.0.1
    • 5.1.0
    • 5.1.1
    • 5.2
    • 5.3.0
    • 6.0.0
    • 6.0.1
    • 6.0.2
    • 7.0.0
    • 7.0.1
    • 7.0.2
    • 7.0.3
    • 7.0.4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 8.0.0

    Actualiza a 8.0.0

  • mitmproxy PyPI

    Versiones
    • 0.10
    • 0.10.1
    • 0.11
    • 0.11.1
    • 0.11.2
    • 0.11.3
    • 0.12.0
    • 0.12.1
    • 0.13
    • 0.14.0
    • 0.15
    • 0.16
    • 0.17
    • 0.18.1
    • 0.18.2
    • 0.18.3
    • 0.8
    • 0.8.1
    • 0.9
    • 0.9.1
    • 0.9.2
    • 1.0.0
    • 1.0.1
    • 1.0.2
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 4.0.0
    • 4.0.1
    • 4.0.3
    • 4.0.4
    • 5.0.0
    • 5.0.1
    • 5.1.0
    • 5.1.1
    • 5.2
    • 5.3.0
    • 6.0.0
    • 6.0.1
    • 6.0.2
    • 7.0.0
    • 7.0.1
    • 7.0.2
    • 7.0.3
    • 7.0.4
    Intervalos de versiones afectados
    • GIT: < b06fb6d157087d526bd02e7aadbe37c56865c71b
    • ECOSYSTEM: < 8.0.0

    Actualiza a 8.0.0

  • mitmproxy Ubuntu:16.04:LTS

    Versiones
    • 0.11.3-3
    • 0.12.1-2
    • 0.13-1
    • 0.15-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mitmproxy Ubuntu:18.04:LTS

    Versiones
    • 2.0.2-2
    • 2.0.2-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mitmproxy Ubuntu:20.04:LTS

    Versiones
    • 4.0.4-6
    • 4.0.4-6.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mitmproxy Ubuntu:22.04:LTS

    Versiones
    • 6.0.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mitmproxy Ubuntu:24.04:LTS

    Versiones
    • 8.1.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mitmproxy Ubuntu:25.10

    Versiones
    • 8.1.1-2
    • 8.1.1-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mitmproxy Ubuntu:26.10

    Versiones
    • 8.1.1-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mitmproxy Ubuntu:26.04:LTS

    Versiones
    • 8.1.1-3
    • 8.1.1-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →