CVE-2022-24834
CVE-2022-24834 · Heap overflow issue with the Lua cjson library used by Redis
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Redis is an in-memory database that persists on disk. A specially crafted Lua script executing in Redis can trigger a heap overflow in the cjson library, and result with heap corruption and potentially remote code execution. The problem exists in all versions of Redis with Lua scripting support, starting from 2.6, and affects only authenticated and authorized users. The problem is fixed in versions 7.0.12, 6.2.13, and 6.0.20.
CVSS 7.0 · Alta · EPSS 41,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
redis
- Versiones
- >= 7.0.0, < 7.0.12: Afectada
- >= 6.2.0, < 6.2.13: Afectada
- >= 6.0.0, < 6.0.20: Afectada
Sin corrección publicada
redis Debian:12
- Versiones
- 5:7.0.11-1
- 5:7.0.11-1+deb12u1
- 5:7.0.12-1
- 5:7.0.12-2
- 5:7.0.13-1
- 5:7.0.13-2
- 5:7.0.14-1
- 5:7.0.14-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-1~deb12u1
Actualiza a 5:7.0.15-1~deb12u1
redis Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.12-1
Actualiza a 5:7.0.12-1
redis Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.12-1
Actualiza a 5:7.0.12-1
redis Ubuntu:Pro:14.04:LTS
- Versiones
- 2:2.6.13-1
- 2:2.6.16-3
- 2:2.8.0-1
- 2:2.8.2-1
- 2:2.8.4-2
- 2:2.8.4-2ubuntu0.2
- 2:2.8.4-2ubuntu0.2+esm1
- 2:2.8.4-2ubuntu0.2+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:2.8.4-2ubuntu0.2+esm3
Actualiza a 2:2.8.4-2ubuntu0.2+esm3
redis Ubuntu:Pro:16.04:LTS
- Versiones
- 2:3.0.3-3
- 2:3.0.5-1
- 2:3.0.5-2
- 2:3.0.5-3
- 2:3.0.5-4
- 2:3.0.6-1
- 2:3.0.6-1ubuntu0.2
- 2:3.0.6-1ubuntu0.3
- 2:3.0.6-1ubuntu0.4
- 2:3.0.6-1ubuntu0.4+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:3.0.6-1ubuntu0.4+esm2
Actualiza a 2:3.0.6-1ubuntu0.4+esm2
lua-cjson Ubuntu:16.04:LTS
- Versiones
- 2.1.0+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
lua-cjson Ubuntu:18.04:LTS
- Versiones
- 2.1.0+dfsg-2
- 2.1.0+dfsg-2.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
redis Ubuntu:Pro:18.04:LTS
- Versiones
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- 5:4.0.9-1ubuntu0.2+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm4
Actualiza a 5:4.0.9-1ubuntu0.2+esm4
lua-cjson Ubuntu:Pro:20.04:LTS
- Versiones
- 2.1.0+dfsg-2.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.0+dfsg-2.1ubuntu0.20.04.1~esm2
Actualiza a 2.1.0+dfsg-2.1ubuntu0.20.04.1~esm2
redis Ubuntu:Pro:20.04:LTS
- Versiones
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- 5:5.0.7-2ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm2
Actualiza a 5:5.0.7-2ubuntu0.1+esm2
lua-cjson Ubuntu:Pro:22.04:LTS
- Versiones
- 2.1.0+dfsg-2.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.0+dfsg-2.1ubuntu0.22.04.1~esm2
Actualiza a 2.1.0+dfsg-2.1ubuntu0.22.04.1~esm2
redis Ubuntu:Pro:22.04:LTS
- Versiones
- 5:6.0.15-1
- 5:6.0.16-1
- 5:6.0.16-1build1
- 5:6.0.16-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:6.0.16-1ubuntu1+esm1
Actualiza a 5:6.0.16-1ubuntu1+esm1
lua-cjson Ubuntu:24.04:LTS
- Versiones
- 2.1.0+dfsg-2.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
lua-cjson Ubuntu:25.10
- Versiones
- 2.1.0+dfsg-2.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
lua-cmsgpack Ubuntu:25.10
- Versiones
- 0.4.0~git20230328.57b1f90-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
lua-cjson Ubuntu:26.10
- Versiones
- 2.1.0+dfsg-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
lua-cmsgpack Ubuntu:26.10
- Versiones
- 0.4.0~git20230328.57b1f90-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
lua-cjson Ubuntu:26.04:LTS
- Versiones
- 2.1.0+dfsg-2.2
- 2.1.0+dfsg-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
lua-cmsgpack Ubuntu:26.04:LTS
- Versiones
- 0.4.0~git20230328.57b1f90-2
- 0.4.0~git20230328.57b1f90-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/redis/redis/security/advisories/GHSA-p8x2-9v9q-c838
- https://lists.fedoraproject.org/archives/list/[email protected]/message/TDNNH2ONMVNBQ6LUIAOAGDNFPKXNST5K/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/MIF5MAGYARYUMRFK7PQI7HYXMK2HZE5T/
- https://security.netapp.com/advisory/ntap-20230814-0006/
- https://nvd.nist.gov/vuln/detail/CVE-2022-24834