CVE-2022-24851
CVE-2022-24851 · Stored XSS and path traversal in LDAPAccountManager/lam
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
LDAP Account Manager (LAM) is an open source web frontend for managing entries stored in an LDAP directory. The profile editor tool has an edit profile functionality, the parameters on this page are not properly sanitized and hence leads to stored XSS attacks. An authenticated user can store XSS payloads in the profiles, which gets triggered when any other user try to access the edit profile page. The pdf editor tool has an edit pdf profile functionality, the logoFile parameter in it is not properly sanitized and an user can enter relative paths like ../../../../../../../../../../../../../usr/share/icons/hicolor/48x48/apps/gvim.png via tools like burpsuite. Later when a pdf is exported using the edited profile the pdf icon has the image on that path(if image is present). Both issues require an attacker to be able to login to LAM admin interface. The issue is fixed in version 7.9.1.
CVSS 8.1 · Alta · EPSS 1,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
lam
- Versiones
- < 7.9.1: Afectada
Sin corrección publicada
ldap-account-manager Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.9.1-1
Actualiza a 7.9.1-1
ldap-account-manager Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.9.1-1
Actualiza a 7.9.1-1
ldap-account-manager Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.9.1-1
Actualiza a 7.9.1-1
ldap-account-manager Ubuntu:16.04:LTS
- Versiones
- 4.9-1
- 5.1-1
- 5.2-1
- 5.2-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ldap-account-manager Ubuntu:18.04:LTS
- Versiones
- 5.7-1
- 6.1-1
- 6.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ldap-account-manager Ubuntu:20.04:LTS
- Versiones
- 6.7-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ldap-account-manager Ubuntu:22.04:LTS
- Versiones
- 7.5-1
- 7.7-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/LDAPAccountManager/lam/security/advisories/GHSA-f2fr-cccr-583v
- https://github.com/LDAPAccountManager/lam/issues/170
- https://github.com/LDAPAccountManager/lam/commit/3c6f09a3579e048e224eb5a4c4e3eefaa8bccd49
- https://www.debian.org/security/2022/dsa-5177
- https://nvd.nist.gov/vuln/detail/CVE-2022-24851