CVE-2022-31030
CVE-2022-31030 · containerd CRI plugin: Host memory exhaustion through ExecSync
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.
CVSS 5.5 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · containers
Productos y versiones afectados
containerd
- Versiones
- < 1.5.13: Afectada
- >= 1.6.0, < 1.6.6: Afectada
Sin corrección publicada
containerd Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.6~ds1-1
Actualiza a 1.6.6~ds1-1
containerd Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.6~ds1-1
Actualiza a 1.6.6~ds1-1
containerd Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.6~ds1-1
Actualiza a 1.6.6~ds1-1
containerd Ubuntu:Pro:16.04:LTS
- Versiones
- 0.2.1-0ubuntu4~16.04
- 0.2.3-0ubuntu1~16.04
- 0.2.5-0ubuntu1~16.04.1
- 1.2.6-0ubuntu1~16.04.2
- 1.2.6-0ubuntu1~16.04.3
- 1.2.6-0ubuntu1~16.04.4
- 1.2.6-0ubuntu1~16.04.5
- 1.2.6-0ubuntu1~16.04.6
- 1.2.6-0ubuntu1~16.04.6+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.6+esm2
Actualiza a 1.2.6-0ubuntu1~16.04.6+esm2
containerd Ubuntu:18.04:LTS
- Versiones
- 0.2.5-0ubuntu2
- 1.2.6-0ubuntu1~18.04.1
- 1.2.6-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.1
- 1.3.3-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.3
- 1.3.3-0ubuntu1~18.04.4
- 1.4.4-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.1
- 1.5.2-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.3
- 1.5.5-0ubuntu3~18.04.1
- 1.5.5-0ubuntu3~18.04.2
- 1.5.9-0ubuntu1~18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.9-0ubuntu1~18.04.2
Actualiza a 1.5.9-0ubuntu1~18.04.2
containerd Ubuntu:20.04:LTS
- Versiones
- 1.2.10-0ubuntu1
- 1.3.2-0ubuntu1
- 1.3.3-0ubuntu1
- 1.3.3-0ubuntu2
- 1.3.3-0ubuntu2.1
- 1.3.3-0ubuntu2.2
- 1.3.3-0ubuntu2.3
- 1.4.4-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.1
- 1.5.2-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.3
- 1.5.5-0ubuntu3~20.04.1
- 1.5.5-0ubuntu3~20.04.2
- 1.5.9-0ubuntu1~20.04.1
- 1.5.9-0ubuntu1~20.04.4
- 1.5.9-0ubuntu1~20.04.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.9-0ubuntu1~20.04.6
Actualiza a 1.5.9-0ubuntu1~20.04.6
containerd Ubuntu:22.04:LTS
- Versiones
- 1.5.5-0ubuntu3
- 1.5.9-0ubuntu1
- 1.5.9-0ubuntu2
- 1.5.9-0ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.9-0ubuntu3.1
Actualiza a 1.5.9-0ubuntu3.1
Fuentes originales
- https://github.com/containerd/containerd/security/advisories/GHSA-5ffw-gxpp-mxpf
- https://github.com/containerd/containerd/commit/c1bcabb4541930f643aa36a2b38655e131346382
- http://www.openwall.com/lists/oss-security/2022/06/07/1
- https://www.debian.org/security/2022/dsa-5162
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WSIGDBHAB3I75JBJNGWEPBTJPS2FOVHD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/REOZCUAPCA7NFDWYBDYX6EYXWLHABKBO/
- https://security.gentoo.org/glsa/202401-31
- https://nvd.nist.gov/vuln/detail/CVE-2022-31030