CVE-2022-31091
CVE-2022-31091 · Change in port should be considered a change in origin in Guzzle
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.
Guzzle, an extensible PHP HTTP client. `Authorization` and `Cookie` headers on requests are sensitive information. In affected versions on making a request which responds with a redirect to a URI with a different port, if we choose to follow it, we should remove the `Authorization` and `Cookie` headers from the request, before containing. Previously, we would only consider a change in host or scheme. Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Note that a partial fix was implemented in Guzzle 7.4.2, where a change in host would trigger removal of the curl-added Authorization header, however this earlier fix did not cover change in scheme or change in port. An alternative approach would be to use your own redirect middleware, rather than ours, if you are unable to upgrade. If you do not require or expect redirects to be followed, one should simply disable redirects all together.
CVSS 7.7 · Alta · EPSS 1,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
guzzle
- Versiones
- < 6.5.8: Afectada
- >=7.0.0, < 7.4.5: Afectada
Sin corrección publicada
guzzle Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.4.5-1
Actualiza a 7.4.5-1
guzzle Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.4.5-1
Actualiza a 7.4.5-1
guzzle Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.4.5-1
Actualiza a 7.4.5-1
mediawiki Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:1.35.7-1
Actualiza a 1:1.35.7-1
mediawiki Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:1.35.7-1
Actualiza a 1:1.35.7-1
mediawiki Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:1.35.7-1
Actualiza a 1:1.35.7-1
guzzlehttp/guzzle Packagist
- Versiones
- 4.0.0
- 4.0.0-rc.1
- 4.0.0-rc.2
- 4.0.1
- 4.0.2
- 4.1.0
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1.7
- 4.1.8
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 5.0.0
- 5.0.1
- 5.0.2
- 5.0.3
- 5.1.0
- 5.2.0
- 5.3.0
- 5.3.1
- 5.3.2
- 5.3.3
- 5.3.4
- 6.0.0
- 6.0.1
- 6.0.2
- 6.1.0
- 6.1.1
- 6.2.0
- 6.2.1
- 6.2.2
- 6.2.3
- 6.3.0
- 6.3.1
- 6.3.2
- 6.3.3
- 6.4.0
- 6.4.1
- 6.5.0
- 6.5.1
- 6.5.2
- 6.5.3
- 6.5.4
- 6.5.5
- 6.5.6
- 6.5.7
- v1.0.3
- v1.0.4
- v2.0.0
- v2.0.1
- v2.0.2
- v2.0.3
- v2.0.4
- v2.0.5
- v2.1.0
- v2.1.1
- v2.1.2
- v2.1.3
- v2.1.4
- v2.2.0
- v2.2.1
- v2.2.2
- v2.2.3
- v2.2.4
- v2.3.2
- v2.4.0
- v2.4.1
- v2.5.0
- v2.6.0
- v2.6.1
- v2.6.2
- v2.6.3
- v2.6.4
- v2.6.5
- v2.6.6
- v2.7.0
- v2.7.1
- v2.7.2
- v2.8.0
- v2.8.1
- v2.8.2
- v2.8.3
- v2.8.4
- v2.8.5
- v2.8.6
- v2.8.7
- v2.8.8
- v3.0.0
- v3.0.1
- v3.0.2
- v3.0.3
- v3.0.4
- v3.0.5
- v3.0.6
- v3.0.7
- v3.1.0
- v3.1.1
- v3.1.2
- v3.2.0
- v3.3.0
- v3.3.1
- v3.4.0
- v3.4.1
- v3.4.2
- v3.4.3
- v3.5.0
- v3.6.0
- v3.7.0
- v3.7.1
- v3.7.2
- v3.7.3
- v3.7.4
- v3.8.0
- v3.8.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.5.8
Actualiza a 6.5.8
guzzlehttp/guzzle Packagist
- Versiones
- 7.0.0
- 7.0.1
- 7.1.0
- 7.1.1
- 7.2.0
- 7.3.0
- 7.4.0
- 7.4.1
- 7.4.2
- 7.4.3
- 7.4.4
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 7.0.0, < 7.4.5
Actualiza a 7.4.5
civicrm Ubuntu:Pro:16.04:LTS
- Versiones
- 4.7.1+dfsg-1
- 4.7.1+dfsg-2
- 4.7.1+dfsg-2ubuntu1
- 4.7.1+dfsg-2ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
civicrm Ubuntu:Pro:18.04:LTS
- Versiones
- 4.7.23+dfsg-1ubuntu1
- 4.7.24+dfsg-1ubuntu1
- 4.7.30+dfsg-1ubuntu1
- 4.7.30+dfsg-1ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mediawiki Ubuntu:18.04:LTS
- Versiones
- 1:1.27.3-1
- 1:1.27.4-1
- 1:1.27.4-2
- 1:1.27.4-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
civicrm Ubuntu:Pro:20.04:LTS
- Versiones
- 5.11.0+dfsg-1
- 5.18.1+dfsg-1
- 5.20.3+dfsg-1
- 5.21.0+dfsg-1
- 5.21.1+dfsg-1
- 5.21.2+dfsg-1
- 5.21.2+dfsg-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mediawiki Ubuntu:Pro:20.04:LTS
- Versiones
- 1:1.31.2-1ubuntu1
- 1:1.31.5-1
- 1:1.31.5-1ubuntu1
- 1:1.31.5-2
- 1:1.31.5-3
- 1:1.31.5-3ubuntu1
- 1:1.31.6-1
- 1:1.31.7-1
- 1:1.31.7-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icinga-php-thirdparty Ubuntu:22.04:LTS
- Versiones
- 0.10.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-reactbundle Ubuntu:22.04:LTS
- Versiones
- 0.8.0-1.1
- 0.9.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
civicrm Ubuntu:Pro:22.04:LTS
- Versiones
- 5.33.2+dfsg1-1
- 5.33.2+dfsg1-1build1
- 5.33.2+dfsg1-1ubuntu1
- 5.33.2+dfsg1-1ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
mediawiki Ubuntu:Pro:22.04:LTS
- Versiones
- 1:1.35.3-1
- 1:1.35.4-1
- 1:1.35.5-1
- 1:1.35.5-1ubuntu1
- 1:1.35.5-1ubuntu2
- 1:1.35.5-1ubuntu3
- 1:1.35.6-1
- 1:1.35.6-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icinga-php-thirdparty Ubuntu:24.04:LTS
- Versiones
- 0.11.0-2
- 0.12.0+ds-1
- 0.12.1+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-reactbundle Ubuntu:24.04:LTS
- Versiones
- 0.9.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icinga-php-thirdparty Ubuntu:25.10
- Versiones
- 0.12.1+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-reactbundle Ubuntu:25.10
- Versiones
- 0.9.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icinga-php-thirdparty Ubuntu:26.10
- Versiones
- 0.14.0+ds-1
- 0.15.2-1
- 0.15.3-1
- 1.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
icingaweb2-module-reactbundle Ubuntu:26.10
- Versiones
- 0.9.0-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada