p PatchFirst

CVE-2022-31108

CVE-2022-31108 · Arbitrary `CSS` injection into the generated graph affecting the container HTML in mermaid.js

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. An attacker is able to inject arbitrary `CSS` into the generated graph allowing them to change the styling of elements outside of the generated graph, and potentially exfiltrate sensitive information by using specially crafted `CSS` selectors. The following example shows how an attacker can exfiltrate the contents of an input field by bruteforcing the `value` attribute one character at a time. Whenever there is an actual match, an `http` request will be made by the browser in order to "load" a background image that will let an attacker know what's the value of the character. This issue may lead to `Information Disclosure` via CSS selectors and functions able to generate HTTP requests. This also allows an attacker to change the document in ways which may lead a user to perform unintended actions, such as clicking on a link, etc. This issue has been resolved in version 9.1.3. Users are advised to upgrade. Users unable to upgrade should ensure that user input is adequately escaped before embedding it in CSS blocks.

CVSS 4.1 · Media · EPSS 0,9% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • mermaid

    Versiones
    • >= 8.0.0, < 9.1.3: Afectada

    Sin corrección publicada

  • node-mermaid Debian:14

    Versiones
    • 8.11.0+ds+~cs29.13.22-1
    • 8.13.2+ds+~cs30.13.21-1
    • 8.13.2+ds+~cs30.13.21-1.1
    • 8.13.3+ds+~cs26.13.21-1
    • 8.13.3+ds+~cs26.13.21-2
    • 8.13.8+~cs10.4.16-1
    • 8.14.0+ds1+~cs11.4.14-1
    • 8.14.0+~cs11.4.14-1
    • 8.7.0+ds+~cs27.17.17-1
    • 8.7.0+ds+~cs27.17.17-2
    • 8.7.0+ds+~cs27.17.17-2~bpo10+1
    • 8.7.0+ds+~cs27.17.17-3
    • 8.9.1+ds+~cs26.20.25-1
    • 8.9.3+ds+~cs29.13.19-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.2.2+~2.0.0-1

    Actualiza a 9.2.2+~2.0.0-1

  • mermaid npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 8.0.0, < 9.1.2

    Actualiza a 9.1.2

  • node-mermaid Ubuntu:22.04:LTS

    Versiones
    • 8.7.0+ds+~cs27.17.17-3
    • 8.13.3+ds+~cs26.13.21-1
    • 8.13.3+ds+~cs26.13.21-2
    • 8.13.8+~cs10.4.16-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-mermaid Ubuntu:26.10

    Versiones
    • 9.2.2+~2.0.0-1
    • 9.2.2+~2.0.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →