p PatchFirst

CVE-2022-32206

CVE-2022-32206

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

curl < 7.84.0 supports "chained" HTTP compression algorithms, meaning that a serverresponse can be compressed multiple times and potentially with different algorithms. The number of acceptable "links" in this "decompression chain" was unbounded, allowing a malicious server to insert a virtually unlimited number of compression steps.The use of such a decompression chain could result in a "malloc bomb", makingcurl end up spending enormous amounts of allocated heap memory, or trying toand returning out of memory errors.

CVSS 6.5 · Media · EPSS 36,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • https://github.com/curl/curl

    Versiones
    • Fixed in 7.84.0: Afectada

    Sin corrección publicada

  • curl Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.84.0-1

    Actualiza a 7.84.0-1

  • curl Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.84.0-1

    Actualiza a 7.84.0-1

  • curl Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.84.0-1

    Actualiza a 7.84.0-1

  • curl Ubuntu:18.04:LTS

    Versiones
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    • 7.58.0-2ubuntu3.1
    • 7.58.0-2ubuntu3.2
    • 7.58.0-2ubuntu3.3
    • 7.58.0-2ubuntu3.5
    • 7.58.0-2ubuntu3.6
    • 7.58.0-2ubuntu3.7
    • 7.58.0-2ubuntu3.8
    • 7.58.0-2ubuntu3.9
    • 7.58.0-2ubuntu3.10
    • 7.58.0-2ubuntu3.12
    • 7.58.0-2ubuntu3.13
    • 7.58.0-2ubuntu3.14
    • 7.58.0-2ubuntu3.15
    • 7.58.0-2ubuntu3.16
    • 7.58.0-2ubuntu3.17
    • 7.58.0-2ubuntu3.18
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.58.0-2ubuntu3.19

    Actualiza a 7.58.0-2ubuntu3.19

  • curl Ubuntu:20.04:LTS

    Versiones
    • 7.65.3-1ubuntu3
    • 7.65.3-1ubuntu4
    • 7.66.0-1ubuntu1
    • 7.67.0-2ubuntu1
    • 7.68.0-1ubuntu1
    • 7.68.0-1ubuntu2
    • 7.68.0-1ubuntu2.1
    • 7.68.0-1ubuntu2.2
    • 7.68.0-1ubuntu2.4
    • 7.68.0-1ubuntu2.5
    • 7.68.0-1ubuntu2.6
    • 7.68.0-1ubuntu2.7
    • 7.68.0-1ubuntu2.10
    • 7.68.0-1ubuntu2.11
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.68.0-1ubuntu2.12

    Actualiza a 7.68.0-1ubuntu2.12

  • curl Ubuntu:22.04:LTS

    Versiones
    • 7.74.0-1.3ubuntu2
    • 7.74.0-1.3ubuntu3
    • 7.80.0-3
    • 7.81.0-1
    • 7.81.0-1ubuntu1.1
    • 7.81.0-1ubuntu1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.81.0-1ubuntu1.3

    Actualiza a 7.81.0-1ubuntu1.3

Fuentes originales

Comprueba tu servidor →