p PatchFirst

CVE-2022-32208

CVE-2022-32208

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

When curl < 7.84.0 does FTP transfers secured by krb5, it handles message verification failures wrongly. This flaw makes it possible for a Man-In-The-Middle attack to go unnoticed and even allows it to inject data to the client.

CVSS 5.9 · Media · EPSS 8,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • https://github.com/curl/curl

    Versiones
    • Fixed in 7.84.0: Afectada

    Sin corrección publicada

  • curl Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.84.0-1

    Actualiza a 7.84.0-1

  • curl Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.84.0-1

    Actualiza a 7.84.0-1

  • curl Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.84.0-1

    Actualiza a 7.84.0-1

  • curl Ubuntu:Pro:14.04:LTS

    Versiones
    • 7.32.0-1ubuntu1
    • 7.33.0-1ubuntu1
    • 7.34.0-1ubuntu1
    • 7.35.0-1ubuntu1
    • 7.35.0-1ubuntu2
    • 7.35.0-1ubuntu2.1
    • 7.35.0-1ubuntu2.2
    • 7.35.0-1ubuntu2.3
    • 7.35.0-1ubuntu2.5
    • 7.35.0-1ubuntu2.6
    • 7.35.0-1ubuntu2.7
    • 7.35.0-1ubuntu2.8
    • 7.35.0-1ubuntu2.9
    • 7.35.0-1ubuntu2.10
    • 7.35.0-1ubuntu2.11
    • 7.35.0-1ubuntu2.12
    • 7.35.0-1ubuntu2.13
    • 7.35.0-1ubuntu2.14
    • 7.35.0-1ubuntu2.15
    • 7.35.0-1ubuntu2.16
    • 7.35.0-1ubuntu2.17
    • 7.35.0-1ubuntu2.19
    • 7.35.0-1ubuntu2.20
    • 7.35.0-1ubuntu2.20+esm2
    • 7.35.0-1ubuntu2.20+esm3
    • 7.35.0-1ubuntu2.20+esm4
    • 7.35.0-1ubuntu2.20+esm5
    • 7.35.0-1ubuntu2.20+esm6
    • 7.35.0-1ubuntu2.20+esm7
    • 7.35.0-1ubuntu2.20+esm8
    • 7.35.0-1ubuntu2.20+esm9
    • 7.35.0-1ubuntu2.20+esm10
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.35.0-1ubuntu2.20+esm11

    Actualiza a 7.35.0-1ubuntu2.20+esm11

  • curl Ubuntu:Pro:16.04:LTS

    Versiones
    • 7.43.0-1ubuntu2
    • 7.45.0-1ubuntu1
    • 7.46.0-1ubuntu1
    • 7.47.0-1ubuntu1
    • 7.47.0-1ubuntu2
    • 7.47.0-1ubuntu2.1
    • 7.47.0-1ubuntu2.2
    • 7.47.0-1ubuntu2.3
    • 7.47.0-1ubuntu2.4
    • 7.47.0-1ubuntu2.5
    • 7.47.0-1ubuntu2.6
    • 7.47.0-1ubuntu2.7
    • 7.47.0-1ubuntu2.8
    • 7.47.0-1ubuntu2.9
    • 7.47.0-1ubuntu2.11
    • 7.47.0-1ubuntu2.12
    • 7.47.0-1ubuntu2.13
    • 7.47.0-1ubuntu2.14
    • 7.47.0-1ubuntu2.15
    • 7.47.0-1ubuntu2.16
    • 7.47.0-1ubuntu2.18
    • 7.47.0-1ubuntu2.19
    • 7.47.0-1ubuntu2.19+esm1
    • 7.47.0-1ubuntu2.19+esm2
    • 7.47.0-1ubuntu2.19+esm3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.47.0-1ubuntu2.19+esm4

    Actualiza a 7.47.0-1ubuntu2.19+esm4

  • curl Ubuntu:18.04:LTS

    Versiones
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    • 7.58.0-2ubuntu3.1
    • 7.58.0-2ubuntu3.2
    • 7.58.0-2ubuntu3.3
    • 7.58.0-2ubuntu3.5
    • 7.58.0-2ubuntu3.6
    • 7.58.0-2ubuntu3.7
    • 7.58.0-2ubuntu3.8
    • 7.58.0-2ubuntu3.9
    • 7.58.0-2ubuntu3.10
    • 7.58.0-2ubuntu3.12
    • 7.58.0-2ubuntu3.13
    • 7.58.0-2ubuntu3.14
    • 7.58.0-2ubuntu3.15
    • 7.58.0-2ubuntu3.16
    • 7.58.0-2ubuntu3.17
    • 7.58.0-2ubuntu3.18
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.58.0-2ubuntu3.19

    Actualiza a 7.58.0-2ubuntu3.19

  • curl Ubuntu:20.04:LTS

    Versiones
    • 7.65.3-1ubuntu3
    • 7.65.3-1ubuntu4
    • 7.66.0-1ubuntu1
    • 7.67.0-2ubuntu1
    • 7.68.0-1ubuntu1
    • 7.68.0-1ubuntu2
    • 7.68.0-1ubuntu2.1
    • 7.68.0-1ubuntu2.2
    • 7.68.0-1ubuntu2.4
    • 7.68.0-1ubuntu2.5
    • 7.68.0-1ubuntu2.6
    • 7.68.0-1ubuntu2.7
    • 7.68.0-1ubuntu2.10
    • 7.68.0-1ubuntu2.11
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.68.0-1ubuntu2.12

    Actualiza a 7.68.0-1ubuntu2.12

  • curl Ubuntu:22.04:LTS

    Versiones
    • 7.74.0-1.3ubuntu2
    • 7.74.0-1.3ubuntu3
    • 7.80.0-3
    • 7.81.0-1
    • 7.81.0-1ubuntu1.1
    • 7.81.0-1ubuntu1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.81.0-1ubuntu1.3

    Actualiza a 7.81.0-1ubuntu1.3

Fuentes originales

Comprueba tu servidor →