p PatchFirst

CVE-2022-39231

CVE-2022-39231 · Parse Server subject to Improper Authentication allowing Auth adapter app ID validation to be circumvented

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.16, or from 5.0.0 to 5.2.6, validation of the authentication adapter app ID for _Facebook_ and _Spotify_ may be circumvented. Configurations which allow users to authenticate using the Parse Server authentication adapter where `appIds` is set as a string instead of an array of strings authenticate requests from an app with a different app ID than the one specified in the `appIds` configuration. For this vulnerability to be exploited, an attacker needs to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. This issue is patched in versions 4.10.16 and 5.2.7. There are no known workarounds.

CVSS 3.7 · Baja · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • parse-server

    Versiones
    • < 4.10.16: Afectada
    • >= 5.0.0, < 5.2.7: Afectada

    Sin corrección publicada

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: < 4.10.16

    Actualiza a 4.10.16

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 5.0.0, < 5.2.7

    Actualiza a 5.2.7

Fuentes originales

Comprueba tu servidor →