CVE-2022-39348
CVE-2022-39348 · Twisted vulnerable to NameVirtualHost Host header injection
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Twisted is an event-based framework for internet applications. Started with version 0.9.4, when the host header does not match a configured host `twisted.web.vhost.NameVirtualHost` will return a `NoResource` resource which renders the Host header unescaped into the 404 response allowing HTML and script injection. In practice this should be very difficult to exploit as being able to modify the Host header of a normal HTTP request implies that one is already in a privileged position. This issue was fixed in version 22.10.0rc1. There are no known workarounds.
CVSS 5.4 · Media · EPSS 1,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
twisted
- Versiones
- >= 0.9.4, < 22.10.0rc1: Afectada
Sin corrección publicada
twisted Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 22.4.0-4
Actualiza a 22.4.0-4
twisted Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 22.4.0-4
Actualiza a 22.4.0-4
twisted Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 22.4.0-4
Actualiza a 22.4.0-4
twisted PyPI
- Versiones
- 1.0.1
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.1.0
- 1.1.1
- 1.2.0
- 10.0.0
- 10.1.0
- 10.2.0
- 11.0.0
- 11.1.0
- 12.0.0
- 12.1.0
- 12.2.0
- 12.3.0
- 13.0.0
- 13.1.0
- 13.2.0
- 14.0.0
- 14.0.1
- 14.0.2
- 15.0.0
- 15.1.0
- 15.2.0
- 15.2.1
- 15.3.0
- 15.4.0
- 15.5.0
- 16.0.0
- 16.1.0
- 16.1.1
- 16.2.0
- 16.3.0
- 16.3.1
- 16.3.2
- 16.4.0
- 16.4.1
- 16.5.0
- 16.5.0rc1
- 16.5.0rc2
- 16.6.0
- 16.6.0rc1
- 16.7.0rc1
- 16.7.0rc2
- 17.1.0
- 17.1.0rc1
- 17.5.0
- 17.9.0
- 17.9.0rc1
- 18.4.0
- 18.4.0rc1
- 18.7.0
- 18.7.0rc1
- 18.7.0rc2
- 18.9.0
- 18.9.0rc1
- 19.10.0
- 19.10.0rc1
- 19.2.0
- 19.2.0rc1
- 19.2.0rc2
- 19.2.1
- 19.7.0
- 19.7.0rc1
- 2.1.0
- 2.4.0
- 2.5.0
- 20.3.0
- 20.3.0rc1
- 21.2.0
- 21.2.0rc1
- 21.7.0
- 21.7.0rc1
- 21.7.0rc2
- 21.7.0rc3
- 22.1.0
- 22.1.0rc1
- 22.2.0
- 22.2.0rc1
- 22.4.0
- 22.4.0rc1
- 22.8.0
- 22.8.0rc1
- 8.0.0
- 8.0.1
- 8.1.0
- 8.2.0
- 9.0.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.9.4, < 22.10.0rc1
Actualiza a 22.10.0rc1
twisted Ubuntu:Pro:14.04:LTS
- Versiones
- 13.0.0-1ubuntu1
- 13.2.0-1ubuntu1
- 13.2.0-1ubuntu1.2
- 13.2.0-1ubuntu1.2+esm1
- 13.2.0-1ubuntu1.2+esm2
- 13.2.0-1ubuntu1.2+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
twisted Ubuntu:Pro:16.04:LTS
- Versiones
- 15.2.1-1ubuntu2
- 15.5.0-1
- 15.5.0-2
- 15.5.0-2ubuntu1
- 15.5.0-4
- 16.0.0~pre1-1
- 16.0.0~pre1-1ubuntu1
- 16.0.0~pre1-2ubuntu1
- 16.0.0~pre1-3
- 16.0.0-1
- 16.0.0-1ubuntu0.2
- 16.0.0-1ubuntu0.4
- 16.0.0-1ubuntu0.4+esm1
- 16.0.0-1ubuntu0.4+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
twisted Ubuntu:Pro:18.04:LTS
- Versiones
- 16.6.0-2ubuntu3
- 17.9.0-1
- 17.9.0-2
- 17.9.0-2ubuntu0.1
- 17.9.0-2ubuntu0.3
- 17.9.0-2ubuntu0.3+esm1
- 17.9.0-2ubuntu0.3+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
twisted Ubuntu:20.04:LTS
- Versiones
- 18.9.0-3ubuntu1
- 18.9.0-5
- 18.9.0-6
- 18.9.0-6build1
- 18.9.0-6ubuntu1
- 18.9.0-8
- 18.9.0-11
- 18.9.0-11ubuntu0.20.04.1
- 18.9.0-11ubuntu0.20.04.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.9.0-11ubuntu0.20.04.3
Actualiza a 18.9.0-11ubuntu0.20.04.3
twisted Ubuntu:22.04:LTS
- Versiones
- 20.3.0-7ubuntu1
- 20.3.0-7ubuntu3
- 22.1.0-2ubuntu2
- 22.1.0-2ubuntu2.1
- 22.1.0-2ubuntu2.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 22.1.0-2ubuntu2.4
Actualiza a 22.1.0-2ubuntu2.4
Fuentes originales
- https://github.com/twisted/twisted/security/advisories/GHSA-vg46-2rrj-3647
- https://github.com/twisted/twisted/commit/f2f5e81c03f14e253e85fe457e646130780db40b
- https://github.com/twisted/twisted/commit/f49041bb67792506d85aeda9cf6157e92f8048f4
- https://lists.debian.org/debian-lts-announce/2022/11/msg00038.html
- https://security.gentoo.org/glsa/202301-02
- https://lists.debian.org/debian-lts-announce/2024/11/msg00028.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-39348