CVE-2022-4743
CVE-2022-4743
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A potential memory leak issue was discovered in SDL2 in GLES_CreateTexture() function in SDL_render_gles.c. The vulnerability allows an attacker to cause a denial of service attack. The vulnerability affects SDL2 v2.0.4 and above. SDL-1.x are not affected.
CVSS 7.5 · Alta · EPSS 1,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
sdl2
- Versiones
- Affects SDL2 v2.0.4 and above, Fixed-in sdl-2.26.0, sdl-prerelease-2.25.1: Afectada
Sin corrección publicada
libsdl2 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.26.0+dfsg-1
Actualiza a 2.26.0+dfsg-1
libsdl2 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.26.0+dfsg-1
Actualiza a 2.26.0+dfsg-1
libsdl2 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.26.0+dfsg-1
Actualiza a 2.26.0+dfsg-1
libsdl2 Ubuntu:Pro:14.04:LTS
- Versiones
- 2.0.0+dfsg1-2
- 2.0.0+dfsg1-3
- 2.0.1+dfsg1-1
- 2.0.1+dfsg1-1ubuntu1
- 2.0.2+dfsg1-3
- 2.0.2+dfsg1-3ubuntu1
- 2.0.2+dfsg1-3ubuntu1.1
- 2.0.2+dfsg1-3ubuntu1.2
- 2.0.2+dfsg1-3ubuntu1.3
- 2.0.2+dfsg1-3ubuntu1.3+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsdl2 Ubuntu:16.04:LTS
- Versiones
- 2.0.2+dfsg1-6ubuntu2
- 2.0.4+dfsg1-2
- 2.0.4+dfsg1-2ubuntu1
- 2.0.4+dfsg1-2ubuntu2
- 2.0.4+dfsg1-2ubuntu2.16.04.1
- 2.0.4+dfsg1-2ubuntu2.16.04.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsdl2 Ubuntu:Pro:18.04:LTS
- Versiones
- 2.0.6+dfsg1-3ubuntu1
- 2.0.6+dfsg1-4ubuntu1
- 2.0.7+dfsg1-3ubuntu1
- 2.0.8+dfsg1-1ubuntu1
- 2.0.8+dfsg1-1ubuntu1.18.04.1
- 2.0.8+dfsg1-1ubuntu1.18.04.3
- 2.0.8+dfsg1-1ubuntu1.18.04.4
- 2.0.8+dfsg1-1ubuntu1.18.04.4+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsdl2 Ubuntu:Pro:20.04:LTS
- Versiones
- 2.0.10+dfsg1-1ubuntu1
- 2.0.10+dfsg1-1ubuntu4
- 2.0.10+dfsg1-1ubuntu6
- 2.0.10+dfsg1-1ubuntu7
- 2.0.10+dfsg1-1ubuntu8
- 2.0.10+dfsg1-2ubuntu5
- 2.0.10+dfsg1-3
- 2.0.10+dfsg1-3ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
libsdl2 Ubuntu:22.04:LTS
- Versiones
- 2.0.14+dfsg2-3
- 2.0.16+dfsg1-5
- 2.0.18+dfsg-4
- 2.0.18+dfsg-5
- 2.0.20+dfsg-2
- 2.0.20+dfsg-2build1
- 2.0.20+dfsg-2ubuntu1.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://bugzilla.redhat.com/show_bug.cgi?id=2156290
- https://access.redhat.com/security/cve/CVE-2022-4743
- https://github.com/libsdl-org/SDL/pull/6269
- https://github.com/libsdl-org/SDL/commit/00b67f55727bc0944c3266e2b875440da132ce4b
- https://lists.debian.org/debian-lts-announce/2023/02/msg00008.html
- https://security.gentoo.org/glsa/202305-18
- https://lists.debian.org/debian-lts-announce/2025/11/msg00024.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-4743