CVE-2023-22727
CVE-2023-22727 · Database Query::offset() and limit() vulnerable to SQL injection in cakephp
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
CakePHP is a development framework for PHP web apps. In affected versions the `Cake\Database\Query::limit()` and `Cake\Database\Query::offset()` methods are vulnerable to SQL injection if passed un-sanitized user request data. This issue has been fixed in 4.2.12, 4.3.11, 4.4.10. Users are advised to upgrade. Users unable to upgrade may mitigate this issue by using CakePHP's Pagination library. Manually validating or casting parameters to these methods will also mitigate the issue.
CVSS 9.8 · Crítica · EPSS 0,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
cakephp
- Versiones
- >= 4.2.0, < 4.2.12: Afectada
- >= 4.3.0, < 4.3.11: Afectada
- >= 4.4.0, < 4.4.10: Afectada
Sin corrección publicada
cakephp/cakephp Packagist
- Versiones
- 4.2.0
- 4.2.1
- 4.2.10
- 4.2.11
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.2.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.2.0, < 4.2.12
Actualiza a 4.2.12
cakephp/cakephp Packagist
- Versiones
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.3.0, < 4.3.11
Actualiza a 4.3.11
cakephp/cakephp Packagist
- Versiones
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.4.8
- 4.4.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.4.0, < 4.4.10
Actualiza a 4.4.10
cakephp/database Packagist
- Versiones
- 4.2.0
- 4.2.1
- 4.2.10
- 4.2.11
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.2.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.2.0, < 4.2.12
Actualiza a 4.2.12
cakephp/database Packagist
- Versiones
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.3.0, < 4.3.11
Actualiza a 4.3.11
cakephp/database Packagist
- Versiones
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.4.8
- 4.4.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.4.0, < 4.4.10
Actualiza a 4.4.10
cakephp Ubuntu:16.04:LTS
- Versiones
- 2.7.2-1
- 2.8.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cakephp Ubuntu:20.04:LTS
- Versiones
- 2.10.11-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cakephp Ubuntu:22.04:LTS
- Versiones
- 2.10.11-2.1
- 2.10.24-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada