CVE-2023-22731
CVE-2023-22731 · Improper Control of Generation of Code in Twig rendered views in shopware
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Shopware is an open source commerce platform based on Symfony Framework and Vue js. In a Twig environment **without the Sandbox extension**, it is possible to refer to PHP functions in twig filters like `map`, `filter`, `sort`. This allows a template to call any global PHP function and thus execute arbitrary code. The attacker must have access to a Twig environment in order to exploit this vulnerability. This problem has been fixed with 6.4.18.1 with an override of the specified filters until the integration of the Sandbox extension has been finished. Users are advised to upgrade. Users of major versions 6.1, 6.2, and 6.3 may also receive this fix via a plugin.
CVSS 10.0 · Crítica · EPSS 1,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
platform
- Versiones
- < 6.4.18.1: Afectada
Sin corrección publicada
shopware/platform Packagist
- Versiones
- 6.3.0.0
- 6.3.0.1
- 6.3.0.2
- 6.3.1.0
- 6.3.1.1
- 6.3.2.0
- 6.3.2.1
- 6.3.3.0
- 6.3.3.1
- 6.3.4.0
- 6.3.4.1
- 6.3.5.0
- 6.3.5.1
- 6.3.5.2
- 6.3.5.3
- 6.3.5.4
- 6.4.0.0
- 6.4.0.0-RC1
- 6.4.1.0
- 6.4.1.1
- 6.4.1.2
- 6.4.10.0
- 6.4.10.1
- 6.4.11.0
- 6.4.11.1
- 6.4.12.0
- 6.4.13.0
- 6.4.14.0
- 6.4.15.0
- 6.4.15.1
- 6.4.15.2
- 6.4.16.0
- 6.4.16.1
- 6.4.17.0
- 6.4.17.1
- 6.4.17.2
- 6.4.18.0
- 6.4.2.0
- 6.4.2.1
- 6.4.3.0
- 6.4.3.1
- 6.4.4.0
- 6.4.4.1
- 6.4.5.0
- 6.4.5.1
- 6.4.6.0
- 6.4.6.1
- 6.4.7.0
- 6.4.8.0
- 6.4.8.1
- 6.4.8.2
- 6.4.9.0
- v6.0.0+ea2
- v6.1.0
- v6.1.0-rc1
- v6.1.0-rc2
- v6.1.0-rc3
- v6.1.0-rc4
- v6.1.1
- v6.1.2
- v6.1.3
- v6.1.4
- v6.1.5
- v6.1.6
- v6.2.0
- v6.2.0-RC1
- v6.2.1
- v6.2.2
- v6.2.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.4.18.1
Actualiza a 6.4.18.1
shopware/core Packagist
- Versiones
- 6.3.0.0
- 6.3.0.1
- 6.3.0.2
- 6.3.1.0
- 6.3.1.1
- 6.3.2.0
- 6.3.2.1
- 6.3.3.0
- 6.3.3.1
- 6.3.4.0
- 6.3.4.1
- 6.3.5.0
- 6.3.5.1
- 6.3.5.2
- 6.3.5.3
- 6.3.5.4
- 6.4.0.0
- 6.4.0.0-RC1
- 6.4.1.0
- 6.4.1.1
- 6.4.1.2
- 6.4.10.0
- 6.4.10.1
- 6.4.11.0
- 6.4.11.1
- 6.4.12.0
- 6.4.13.0
- 6.4.14.0
- 6.4.15.0
- 6.4.15.1
- 6.4.15.2
- 6.4.16.0
- 6.4.16.1
- 6.4.17.0
- 6.4.17.1
- 6.4.17.2
- 6.4.18.0
- 6.4.2.0
- 6.4.2.1
- 6.4.3.0
- 6.4.3.1
- 6.4.4.0
- 6.4.4.1
- 6.4.5.0
- 6.4.5.1
- 6.4.6.0
- 6.4.6.1
- 6.4.7.0
- 6.4.8.0
- 6.4.8.1
- 6.4.8.2
- 6.4.9.0
- v6.0.0+ea2
- v6.1.0
- v6.1.0-rc1
- v6.1.0-rc2
- v6.1.0-rc3
- v6.1.0-rc4
- v6.1.1
- v6.1.2
- v6.1.3
- v6.1.4
- v6.1.5
- v6.1.6
- v6.2.0
- v6.2.0-RC1
- v6.2.1
- v6.2.2
- v6.2.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.4.18.1
Actualiza a 6.4.18.1
Fuentes originales
- https://github.com/shopware/platform/security/advisories/GHSA-93cw-f5jj-x85w
- https://github.com/shopware/platform/commit/89d1ea154689cb6202e0d3a0ceeae0febb0c09e1
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates
- https://nvd.nist.gov/vuln/detail/CVE-2023-22731