CVE-2023-25153
CVE-2023-25153 · containerd OCI image importer memory exhaustion
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
containerd is an open source container runtime. Before versions 1.6.18 and 1.5.18, when importing an OCI image, there was no limit on the number of bytes read for certain files. A maliciously crafted image with a large file where a limit was not applied could cause a denial of service. This bug has been fixed in containerd 1.6.18 and 1.5.18. Users should update to these versions to resolve the issue. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.
CVSS 6.2 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · containers
Productos y versiones afectados
containerd
- Versiones
- < 1.5.18: Afectada
- >= 1.6.0, < 1.6.18: Afectada
Sin corrección publicada
containerd Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.18~ds1-1
Actualiza a 1.6.18~ds1-1
containerd Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.18~ds1-1
Actualiza a 1.6.18~ds1-1
containerd Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.18~ds1-1
Actualiza a 1.6.18~ds1-1
containerd Ubuntu:Pro:16.04:LTS
- Versiones
- 0.2.1-0ubuntu4~16.04
- 0.2.3-0ubuntu1~16.04
- 0.2.5-0ubuntu1~16.04.1
- 1.2.6-0ubuntu1~16.04.2
- 1.2.6-0ubuntu1~16.04.3
- 1.2.6-0ubuntu1~16.04.4
- 1.2.6-0ubuntu1~16.04.5
- 1.2.6-0ubuntu1~16.04.6
- 1.2.6-0ubuntu1~16.04.6+esm1
- 1.2.6-0ubuntu1~16.04.6+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.6+esm4
Actualiza a 1.2.6-0ubuntu1~16.04.6+esm4
containerd Ubuntu:Pro:18.04:LTS
- Versiones
- 0.2.5-0ubuntu2
- 1.2.6-0ubuntu1~18.04.1
- 1.2.6-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.1
- 1.3.3-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.3
- 1.3.3-0ubuntu1~18.04.4
- 1.4.4-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.1
- 1.5.2-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.3
- 1.5.5-0ubuntu3~18.04.1
- 1.5.5-0ubuntu3~18.04.2
- 1.5.9-0ubuntu1~18.04.1
- 1.5.9-0ubuntu1~18.04.2
- 1.6.12-0ubuntu1~18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.12-0ubuntu1~18.04.1+esm1
Actualiza a 1.6.12-0ubuntu1~18.04.1+esm1
containerd Ubuntu:20.04:LTS
- Versiones
- 1.2.10-0ubuntu1
- 1.3.2-0ubuntu1
- 1.3.3-0ubuntu1
- 1.3.3-0ubuntu2
- 1.3.3-0ubuntu2.1
- 1.3.3-0ubuntu2.2
- 1.3.3-0ubuntu2.3
- 1.4.4-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.1
- 1.5.2-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.3
- 1.5.5-0ubuntu3~20.04.1
- 1.5.5-0ubuntu3~20.04.2
- 1.5.9-0ubuntu1~20.04.1
- 1.5.9-0ubuntu1~20.04.4
- 1.5.9-0ubuntu1~20.04.5
- 1.5.9-0ubuntu1~20.04.6
- 1.6.12-0ubuntu1~20.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.12-0ubuntu1~20.04.3
Actualiza a 1.6.12-0ubuntu1~20.04.3
containerd Ubuntu:22.04:LTS
- Versiones
- 1.5.5-0ubuntu3
- 1.5.9-0ubuntu1
- 1.5.9-0ubuntu2
- 1.5.9-0ubuntu3
- 1.5.9-0ubuntu3.1
- 1.6.12-0ubuntu1~22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.12-0ubuntu1~22.04.3
Actualiza a 1.6.12-0ubuntu1~22.04.3
Fuentes originales
- https://github.com/containerd/containerd/security/advisories/GHSA-259w-8hf6-59c2
- https://github.com/containerd/containerd/commit/0c314901076a74a7b797a545d2f462285fdbb8c4
- https://github.com/containerd/containerd/releases/tag/v1.5.18
- https://github.com/containerd/containerd/releases/tag/v1.6.18
- https://nvd.nist.gov/vuln/detail/CVE-2023-25153