p PatchFirst

CVE-2023-25661

CVE-2023-25661 · Denial of Service in TensorFlow

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

TensorFlow is an Open Source Machine Learning Framework. In versions prior to 2.11.1 a malicious invalid input crashes a tensorflow model (Check Failed) and can be used to trigger a denial of service attack. A proof of concept can be constructed with the `Convolution3DTranspose` function. This Convolution3DTranspose layer is a very common API in modern neural networks. The ML models containing such vulnerable components could be deployed in ML applications or as cloud services. This failure could be potentially used to trigger a denial of service attack on ML cloud services. An attacker must have privilege to provide input to a `Convolution3DTranspose` call. This issue has been patched and users are advised to upgrade to version 2.11.1. There are no known workarounds for this vulnerability.

CVSS 6.5 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • tensorflow

    Versiones
    • < 2.11.1: Afectada

    Sin corrección publicada

  • tensorflow PyPI

    Versiones
    • 0.12.0
    • 0.12.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.10.0
    • 1.10.1
    • 1.11.0
    • 1.12.0
    • 1.12.2
    • 1.12.3
    • 1.13.1
    • 1.13.2
    • 1.14.0
    • 1.15.0
    • 1.15.2
    • 1.15.3
    • 1.15.4
    • 1.15.5
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.6.0
    • 1.7.0
    • 1.7.1
    • 1.8.0
    • 1.9.0
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.10.0
    • 2.10.0rc0
    • 2.10.0rc1
    • 2.10.0rc2
    • 2.10.0rc3
    • 2.10.1
    • 2.11.0
    • 2.11.0rc0
    • 2.11.0rc1
    • 2.11.0rc2
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.6.0
    • 2.6.0rc0
    • 2.6.0rc1
    • 2.6.0rc2
    • 2.6.1
    • 2.6.2
    • 2.6.3
    • 2.6.4
    • 2.6.5
    • 2.7.0
    • 2.7.0rc0
    • 2.7.0rc1
    • 2.7.1
    • 2.7.2
    • 2.7.3
    • 2.7.4
    • 2.8.0
    • 2.8.0rc0
    • 2.8.0rc1
    • 2.8.1
    • 2.8.2
    • 2.8.3
    • 2.8.4
    • 2.9.0
    • 2.9.0rc0
    • 2.9.0rc1
    • 2.9.0rc2
    • 2.9.1
    • 2.9.2
    • 2.9.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.11.1

    Actualiza a 2.11.1

  • tensorflow-cpu PyPI

    Versiones
    • 1.15.0
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.10.0
    • 2.10.0rc0
    • 2.10.0rc1
    • 2.10.0rc2
    • 2.10.0rc3
    • 2.10.1
    • 2.11.0
    • 2.11.0rc0
    • 2.11.0rc1
    • 2.11.0rc2
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.6.0
    • 2.6.1
    • 2.6.2
    • 2.6.3
    • 2.6.4
    • 2.6.5
    • 2.7.0
    • 2.7.1
    • 2.7.2
    • 2.7.3
    • 2.7.4
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.8.3
    • 2.8.4
    • 2.9.0
    • 2.9.0rc0
    • 2.9.0rc1
    • 2.9.0rc2
    • 2.9.1
    • 2.9.2
    • 2.9.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.11.1

    Actualiza a 2.11.1

Fuentes originales

Comprueba tu servidor →