CVE-2023-26487
CVE-2023-26487 · Vega has cross-site scripting vulnerability in `lassoAppend` function
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs.`lassoAppend' function accepts 3 arguments and internally invokes `push` function on the 1st argument specifying array consisting of 2nd and 3rd arguments as `push` call argument. The type of the 1st argument is supposed to be an array, but it's not enforced. This makes it possible to specify any object with a `push` function as the 1st argument, `push` function can be set to any function that can be access via `event.view` (no all such functions can be exploited due to invalid context or signature, but some can, e.g. `console.log`). The issue is that`lassoAppend` doesn't enforce proper types of its arguments. This issue opens various XSS vectors, but exact impact and severity depends on the environment (e.g. Core JS `setImmediate` polyfill basically allows `eval`-like functionality). This issue was patched in 5.23.0.
CVSS 6.5 · Media · EPSS 0,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
vega
- Versiones
- < 5.23.0: Afectada
Sin corrección publicada
vega.js Debian:12
- Versiones
- 5.22.1+ds+~3.1.0-4
- 5.25.0+ds+~cs5.3.0-1
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-3
- 5.25.0+ds+~cs5.3.0-4
- 5.25.0+ds+~cs5.3.0-5
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
vega.js Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.25.0+ds+~cs5.3.0-1
Actualiza a 5.25.0+ds+~cs5.3.0-1
vega.js Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.25.0+ds+~cs5.3.0-1
Actualiza a 5.25.0+ds+~cs5.3.0-1
vega npm
- Intervalos de versiones afectados
- SEMVER: < 5.23.0
Actualiza a 5.23.0
vega-functions npm
- Intervalos de versiones afectados
- SEMVER: < 5.13.1
Actualiza a 5.13.1