p PatchFirst

CVE-2023-28097

CVE-2023-28097 · OpenSIPS has vulnerability in the Content-Length Parser

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, a malformed SIP message containing a large _Content-Length_ value and a specially crafted Request-URI causes a segmentation fault in OpenSIPS. This issue occurs when a large amount of shared memory using the `-m` flag was allocated to OpenSIPS, such as 10 GB of RAM. On the test system, this issue occurred when shared memory was set to `2362` or higher. This issue is fixed in versions 3.1.9 and 3.2.6. The only workaround is to guarantee that the Content-Length value of input messages is never larger than `2147483647`.

CVSS 7.5 · Alta · EPSS 1,0%

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • opensips

    Versiones
    • < 3.1.9: Afectada
    • >= 3.2.0, < 3.2.6: Afectada

    Sin corrección publicada

  • opensips Ubuntu:18.04:LTS

    Versiones
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →