p PatchFirst

CVE-2023-29530

CVE-2023-29530 · Laminas Diactoros vulnerable to HTTP Multiline Header Termination

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Laminas Diactoros provides PSR HTTP Message implementations. In versions 2.18.0 and prior, 2.19.0, 2.20.0, 2.21.0, 2.22.0, 2.23.0, 2.24.0, and 2.25.0, users who create HTTP requests or responses using laminas/laminas-diactoros, when providing a newline at the start or end of a header key or value, can cause an invalid message. This can lead to denial of service vectors or application errors. The problem has been patched in following versions 2.18.1, 2.19.1, 2.20.1, 2.21.1, 2.22.1, 2.23.1, 2.24.1, and 2.25.1. As a workaround, validate HTTP header keys and/or values, and if using user-supplied values, filter them to strip off leading or trailing newline characters before calling `withHeader()`.

CVSS 7.5 · Alta · EPSS 1,0% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • laminas-diactoros

    Versiones
    • < 2.18.1: Afectada
    • = 2.19.0: Afectada
    • = 2.20.0: Afectada
    • = 2.21.0: Afectada
    • = 2.22.0: Afectada
    • = 2.23.0: Afectada
    • = 2.24.0: Afectada
    • = 2.25.0: Afectada

    Sin corrección publicada

  • laminas/laminas-diactoros Packagist

    Versiones
    • 1.0.0
    • 1.0.1
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.3.1
    • 1.3.10
    • 1.3.11
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.3.5
    • 1.3.6
    • 1.3.7
    • 1.3.8
    • 1.3.9
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.6.0
    • 1.6.1
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.8.0
    • 1.8.0p1
    • 1.8.0p2
    • 1.8.1
    • 1.8.1p1
    • 1.8.1p2
    • 1.8.2
    • 1.8.2p1
    • 1.8.2p2
    • 1.8.3
    • 1.8.3p1
    • 1.8.3p2
    • 1.8.4
    • 1.8.4p1
    • 1.8.4p2
    • 1.8.5
    • 1.8.5p1
    • 1.8.5p2
    • 1.8.6
    • 1.8.6p1
    • 1.8.6p2
    • 1.8.7
    • 1.8.7p1
    • 1.8.7p2
    • 2.0.0
    • 2.0.0p1
    • 2.0.0p2
    • 2.0.1
    • 2.0.1p1
    • 2.0.1p2
    • 2.0.2
    • 2.0.2p1
    • 2.0.2p2
    • 2.0.3
    • 2.0.3p1
    • 2.0.3p2
    • 2.1.0
    • 2.1.0p1
    • 2.1.0p2
    • 2.1.1
    • 2.1.1p1
    • 2.1.1p2
    • 2.1.2
    • 2.1.2p1
    • 2.1.2p2
    • 2.1.3
    • 2.1.3p1
    • 2.1.3p2
    • 2.1.4
    • 2.1.4p1
    • 2.1.4p2
    • 2.1.5
    • 2.1.5p1
    • 2.1.5p2
    • 2.10.0
    • 2.11.0
    • 2.11.1
    • 2.11.2
    • 2.11.3
    • 2.12.0
    • 2.13.0
    • 2.14.0
    • 2.15.0
    • 2.16.0
    • 2.17.0
    • 2.18.0
    • 2.2.0
    • 2.2.0p1
    • 2.2.0p2
    • 2.2.1
    • 2.2.1p1
    • 2.2.1p2
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.4.0
    • 2.4.1
    • 2.5.0
    • 2.5.1
    • 2.6.0
    • 2.7.0
    • 2.8.0
    • 2.9.0
    • 2.9.1
    • 2.9.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.18.1

    Actualiza a 2.18.1

  • laminas/laminas-diactoros Packagist

    Versiones
    • 2.19.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.19.0, < 2.19.1

    Actualiza a 2.19.1

  • laminas/laminas-diactoros Packagist

    Versiones
    • 2.20.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.20.0, < 2.20.1

    Actualiza a 2.20.1

  • laminas/laminas-diactoros Packagist

    Versiones
    • 2.21.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.21.0, < 2.21.1

    Actualiza a 2.21.1

  • laminas/laminas-diactoros Packagist

    Versiones
    • 2.22.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.22.0, < 2.22.1

    Actualiza a 2.22.1

  • laminas/laminas-diactoros Packagist

    Versiones
    • 2.23.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.23.0, < 2.23.1

    Actualiza a 2.23.1

  • laminas/laminas-diactoros Packagist

    Versiones
    • 2.24.0
    • 2.24.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.24.0, < 2.24.2

    Actualiza a 2.24.2

  • laminas/laminas-diactoros Packagist

    Versiones
    • 2.25.0
    • 2.25.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.25.0, < 2.25.2

    Actualiza a 2.25.2

Fuentes originales

Comprueba tu servidor →