p PatchFirst

CVE-2023-32675

CVE-2023-32675 · Nonpayable default functions are sometimes payable in vyper

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In contracts with more than one regular nonpayable function, it is possible to send funds to the default function, even if the default function is marked `nonpayable`. This applies to contracts compiled with vyper versions prior to 0.3.8. This issue was fixed by the removal of the global `calldatasize` check in commit `02339dfda`. Users are advised to upgrade to version 0.3.8. Users unable to upgrade should avoid use of nonpayable default functions.

CVSS 3.7 · Baja · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • vyper

    Versiones
    • < 0.3.8: Afectada

    Sin corrección publicada

  • vyper PyPI

    Versiones
    • 0.1.0b1
    • 0.1.0b10
    • 0.1.0b11
    • 0.1.0b12
    • 0.1.0b13
    • 0.1.0b14
    • 0.1.0b15
    • 0.1.0b16
    • 0.1.0b17
    • 0.1.0b2
    • 0.1.0b3
    • 0.1.0b4
    • 0.1.0b5
    • 0.1.0b6
    • 0.1.0b7
    • 0.1.0b8
    • 0.1.0b9
    • 0.2.1
    • 0.2.10
    • 0.2.11
    • 0.2.12
    • 0.2.13
    • 0.2.14
    • 0.2.15
    • 0.2.16
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 0.2.8
    • 0.2.9
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.3.8

    Actualiza a 0.3.8

  • vyper PyPI

    Versiones
    • 0.1.0b1
    • 0.1.0b10
    • 0.1.0b11
    • 0.1.0b12
    • 0.1.0b13
    • 0.1.0b14
    • 0.1.0b15
    • 0.1.0b16
    • 0.1.0b17
    • 0.1.0b2
    • 0.1.0b3
    • 0.1.0b4
    • 0.1.0b5
    • 0.1.0b6
    • 0.1.0b7
    • 0.1.0b8
    • 0.1.0b9
    • 0.2.1
    • 0.2.10
    • 0.2.11
    • 0.2.12
    • 0.2.13
    • 0.2.14
    • 0.2.15
    • 0.2.16
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 0.2.8
    • 0.2.9
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    Intervalos de versiones afectados
    • GIT: < 02339dfda0f3caabad142060d511d10bfe93c520.
    • ECOSYSTEM: < 0.3.8

    Actualiza a 0.3.8

Fuentes originales

Comprueba tu servidor →