CVE-2023-34459
CVE-2023-34459 · OpenZeppelin Contracts's MerkleProof multiproofs may allow proving arbitrary leaves for specific trees
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
OpenZeppelin Contracts is a library for smart contract development. Starting in version 4.7.0 and prior to version 4.9.2, when the `verifyMultiProof`, `verifyMultiProofCalldata`, `procesprocessMultiProof`, or `processMultiProofCalldat` functions are in use, it is possible to construct merkle trees that allow forging a valid multiproof for an arbitrary set of leaves. A contract may be vulnerable if it uses multiproofs for verification and the merkle tree that is processed includes a node with value 0 at depth 1 (just under the root). This could happen inadvertedly for balanced trees with 3 leaves or less, if the leaves are not hashed. This could happen deliberately if a malicious tree builder includes such a node in the tree. A contract is not vulnerable if it uses single-leaf proving (`verify`, `verifyCalldata`, `processProof`, or `processProofCalldata`), or if it uses multiproofs with a known tree that has hashed leaves. Standard merkle trees produced or validated with the @openzeppelin/merkle-tree library are safe. The problem has been patched in version 4.9.2. Some workarounds are available. For those using multiproofs: When constructing merkle trees hash the leaves and do not insert empty nodes in your trees. Using the @openzeppelin/merkle-tree package eliminates this issue. Do not accept user-provided merkle roots without reconstructing at least the first level of the tree. Verify the merkle tree structure by reconstructing it from the leaves.
CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
openzeppelin-contracts
- Versiones
- >= 4.7.0, < 4.9.2: Afectada
Sin corrección publicada
@openzeppelin/contracts npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.7.0, < 4.9.2
Actualiza a 4.9.2
@openzeppelin/contracts-upgradeable npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.7.0, < 4.9.2
Actualiza a 4.9.2
Fuentes originales
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-wprv-93r4-jj2p
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/4d2383e17186be3e8ccf5a442e9686ecc7de1c55
- https://github.com/OpenZeppelin/openzeppelin-contracts/releases/tag/v4.9.2
- https://nvd.nist.gov/vuln/detail/CVE-2023-34459