CVE-2023-34462
CVE-2023-34462 · netty-handler SniHandler 16MB allocation
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. The `SniHandler` can allocate up to 16MB of heap for each channel during the TLS handshake. When the handler or the channel does not have an idle timeout, it can be used to make a TCP server using the `SniHandler` to allocate 16MB of heap. The `SniHandler` class is a handler that waits for the TLS handshake to configure a `SslHandler` according to the indicated server name by the `ClientHello` record. For this matter it allocates a `ByteBuf` using the value defined in the `ClientHello` record. Normally the value of the packet should be smaller than the handshake packet but there are not checks done here and the way the code is written, it is possible to craft a packet that makes the `SslClientHelloHandler`. This vulnerability has been fixed in version 4.1.94.Final.
CVSS 6.5 · Media · EPSS 2,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
netty
- Versiones
- < 4.1.94.Final: Afectada
Sin corrección publicada
netty Debian:12
- Versiones
- 1:4.1.48-7
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-7+deb12u1
Actualiza a 1:4.1.48-7+deb12u1
netty Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-8
Actualiza a 1:4.1.48-8
netty Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-8
Actualiza a 1:4.1.48-8
netty Ubuntu:22.04:LTS
- Versiones
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-4+deb11u2build0.22.04.1
Actualiza a 1:4.1.48-4+deb11u2build0.22.04.1
netty Ubuntu:24.04:LTS
- Versiones
- 1:4.1.48-7
- 1:4.1.48-8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-9
Actualiza a 1:4.1.48-9
netty Ubuntu:25.10
- Versiones
- 1:4.1.48-10
- 1:4.1.48-10ubuntu0.25.10.1
- 1:4.1.48-10ubuntu0.25.10.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
netty Ubuntu:26.10
- Versiones
- 1:4.1.48-16
- 1:4.1.48-16ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
netty Ubuntu:Pro:26.04:LTS
- Versiones
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-16
- 1:4.1.48-16ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/netty/netty/security/advisories/GHSA-6mjq-h674-j845
- https://github.com/netty/netty/commit/535da17e45201ae4278c0479e6162bb4127d4c32
- https://security.netapp.com/advisory/ntap-20230803-0001/
- https://www.debian.org/security/2023/dsa-5558
- https://security.netapp.com/advisory/ntap-20240621-0007/
- https://nvd.nist.gov/vuln/detail/CVE-2023-34462