CVE-2023-36811
CVE-2023-36811 · Archive spoofing vulnerability in borgbackup
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
borgbackup is an opensource, deduplicating archiver with compression and authenticated encryption. A flaw in the cryptographic authentication scheme in borgbackup allowed an attacker to fake archives and potentially indirectly cause backup data loss in the repository. The attack requires an attacker to be able to: 1. insert files (with no additional headers) into backups and 2. gain write access to the repository. This vulnerability does not disclose plaintext to the attacker, nor does it affect the authenticity of existing archives. Creating plausible fake archives may be feasible for empty or small archives, but is unlikely for large archives. The issue has been fixed in borgbackup 1.2.5. Users are advised to upgrade. Additionally to installing the fixed code, users must follow the upgrade procedure as documented in the change log. Data loss after being attacked can be avoided by reviewing the archives (timestamp and contents valid and as expected) after any "borg check --repair" and before "borg prune". There are no known workarounds for this vulnerability.
CVSS 4.7 · Media · EPSS 0,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
borg
- Versiones
- < 1.2.5: Afectada
Sin corrección publicada
borgbackup Debian:12
- Versiones
- 1.2.4-1
- 1.2.4-2
- 1.2.4-3
- 1.2.5-1
- 1.2.5-2
- 1.2.5-3
- 1.2.5-4
- 1.2.6-1
- 1.2.6-2
- 1.2.7-1
- 1.2.7-2
- 1.2.7-2~bpo12+1
- 1.2.8-1
- 1.2.8-1~bpo12+1
- 1.4.0-1
- 1.4.0-2
- 1.4.0-3
- 1.4.0-4
- 1.4.0-4~bpo12+1
- 1.4.0-5
- 1.4.1-1
- 1.4.1-2
- 1.4.1-3
- 1.4.1-3~exp1
- 1.4.1-4
- 1.4.2-1
- 1.4.2-2
- 1.4.3-1
- 1.4.3-2
- 1.4.3-3
- 1.4.3-4
- 1.4.4-1
- 1.4.4-2
- 1.4.4-3
- 1.4.4-4
- 1.4.4-5
- 1.4.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
borgbackup Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.5-1
Actualiza a 1.2.5-1
borgbackup Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.5-1
Actualiza a 1.2.5-1
borgbackup PyPI
- Versiones
- 0.23.0
- 0.24.0
- 0.25.0
- 0.26.0
- 0.26.1
- 0.27.0
- 0.28.0
- 0.28.1
- 0.28.2
- 0.29.0
- 0.30.0
- 0.30.1
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.1
- 1.0.10
- 1.0.10rc1
- 1.0.11
- 1.0.11rc1
- 1.0.12
- 1.0.13
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.6rc1
- 1.0.7
- 1.0.7rc1
- 1.0.7rc2
- 1.0.8
- 1.0.8rc1
- 1.0.9
- 1.0.9rc1
- 1.1.0
- 1.1.0b1
- 1.1.0b2
- 1.1.0b3
- 1.1.0b4
- 1.1.0b5
- 1.1.0b6
- 1.1.0rc1
- 1.1.0rc2
- 1.1.0rc3
- 1.1.0rc4
- 1.1.1
- 1.1.10
- 1.1.11
- 1.1.12
- 1.1.13
- 1.1.14
- 1.1.15
- 1.1.16
- 1.1.17
- 1.1.18
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.1.7
- 1.1.8
- 1.1.9
- 1.2.0
- 1.2.0a2
- 1.2.0a3
- 1.2.0a4
- 1.2.0a5
- 1.2.0a6
- 1.2.0a7
- 1.2.0a8
- 1.2.0a9
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.0b4
- 1.2.0rc1
- 1.2.1
- 1.2.2
- 1.2.3
- 1.2.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.2.5
Actualiza a 1.2.5
borgbackup PyPI
- Versiones
- 0.23.0
- 0.24.0
- 0.25.0
- 0.26.0
- 0.26.1
- 0.27.0
- 0.28.0
- 0.28.1
- 0.28.2
- 0.29.0
- 0.30.0
- 0.30.1
- 1.0.0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.1
- 1.0.10
- 1.0.10rc1
- 1.0.11
- 1.0.11rc1
- 1.0.12
- 1.0.13
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.6rc1
- 1.0.7
- 1.0.7rc1
- 1.0.7rc2
- 1.0.8
- 1.0.8rc1
- 1.0.9
- 1.0.9rc1
- 1.1.0
- 1.1.0b1
- 1.1.0b2
- 1.1.0b3
- 1.1.0b4
- 1.1.0b5
- 1.1.0b6
- 1.1.0rc1
- 1.1.0rc2
- 1.1.0rc3
- 1.1.0rc4
- 1.1.1
- 1.1.10
- 1.1.11
- 1.1.12
- 1.1.13
- 1.1.14
- 1.1.15
- 1.1.16
- 1.1.17
- 1.1.18
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.1.7
- 1.1.8
- 1.1.9
- 1.2.0
- 1.2.0a2
- 1.2.0a3
- 1.2.0a4
- 1.2.0a5
- 1.2.0a6
- 1.2.0a7
- 1.2.0a8
- 1.2.0a9
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.0b4
- 1.2.0rc1
- 1.2.1
- 1.2.2
- 1.2.3
- 1.2.4
- Intervalos de versiones afectados
- GIT: < 3eb070191da10c2d3f7bc6484cf3d51c3045f884
- ECOSYSTEM: < 1.2.5
Actualiza a 1.2.5
borgbackup Ubuntu:16.04:LTS
- Versiones
- 0.28.1-1
- 0.28.1-2
- 0.28.2-1
- 0.28.2-2
- 0.29.0-1
- 0.29.0-2
- 0.29.0-3
- 0.29.0-4
- 0.30.0-1
- 1.0.0~rc1-1
- 1.0.0~rc1-2
- 1.0.0~rc1-3
- 1.0.0~rc2-1
- 1.0.0~rc2-3
- 1.0.0-1
- 1.0.0-2
- 1.0.0-3
- 1.0.0-4
- 1.0.1-1
- 1.0.2-1
- 1.0.7-0ubuntu1.16.04.1
- 1.0.11-0ubuntu1.16.04.2
- 1.0.12-0ubuntu1.16.04.1
- 1.0.13-0ubuntu1.16.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
borgbackup Ubuntu:18.04:LTS
- Versiones
- 1.0.11-4
- 1.1.2-3
- 1.1.2-4
- 1.1.2-5
- 1.1.3-1build1
- 1.1.3-2
- 1.1.3-3
- 1.1.4-1
- 1.1.4-2
- 1.1.4-2build1
- 1.1.4-3
- 1.1.5-1~build1
- 1.1.5-1
- 1.1.15-1~ubuntu1.18.04.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
borgbackup Ubuntu:20.04:LTS
- Versiones
- 1.1.10-2
- 1.1.10-2build1
- 1.1.11-1~build1
- 1.1.11-1
- 1.1.11-2
- 1.1.11-5~build1
- 1.1.11-5
- 1.1.15-1~ubuntu1.20.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
borgbackup Ubuntu:22.04:LTS
- Versiones
- 1.1.17-1
- 1.1.17-1build1
- 1.2.0-1
- 1.2.0-1ubuntu1.22.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
borgbackup Ubuntu:24.04:LTS
- Versiones
- 1.2.6-2
- 1.2.7-1
- 1.2.7-2
- 1.2.7-2build1
- 1.2.7-2build2
- 1.2.7-2build3
- 1.2.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/borgbackup/borg/security/advisories/GHSA-8fjr-hghr-4m99
- https://github.com/borgbackup/borg/commit/3eb070191da10c2d3f7bc6484cf3d51c3045f884
- https://github.com/borgbackup/borg/blob/1.2.5-cvedocs/docs/changes.rst#pre-125-archives-spoofing-vulnerability-cve-2023-36811
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZUCQSMAWOJBCRGF6XPKEZ2TPGAPNKIWV/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/5Q3OHXERTU547SEQ3YREZXHOCYNLVD63/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/XOZDFIYEBIOKSIEAXUJJJFUJTAJ7TF3C/
- https://nvd.nist.gov/vuln/detail/CVE-2023-36811