CVE-2023-37924
CVE-2023-37924 · Apache Submarine: SQL injection from unauthorized login
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Apache Software Foundation Apache Submarine has an SQL injection vulnerability when a user logs in. This issue can result in unauthorized login. Now we have fixed this issue and now user must have the correct login to access workbench. This issue affects Apache Submarine: from 0.7.0 before 0.8.0. We recommend that all submarine users with 0.7.0 upgrade to 0.8.0, which not only fixes the issue, supports the oidc authentication mode, but also removes the case of unauthenticated logins. If using the version lower than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1037 https://github.com/apache/submarine/pull/1054 and rebuild the submarine-server image to fix this.
CVSS 9.8 · Crítica · EPSS 7,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
apache submarine
- Versiones
- ≥ 0.7.0, < 0.8.0: Afectada (semver)
Actualiza a 0.8.0
apache-submarine PyPI
- Versiones
- 0.7.0
- 0.8.0.dev0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.7.0, < 0.8.0
Actualiza a 0.8.0