p PatchFirst

CVE-2023-38686

CVE-2023-38686 · Sydent does not verify email server certificates

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Sydent is an identity server for the Matrix communications protocol. Prior to version 2.5.6, if configured to send emails using TLS, Sydent does not verify SMTP servers' certificates. This makes Sydent's emails vulnerable to interception via a man-in-the-middle (MITM) attack. Attackers with privileged access to the network can intercept room invitations and address confirmation emails. This is patched in Sydent 2.5.6. When patching, make sure that Sydent trusts the certificate of the server it is connecting to. This should happen automatically when using properly issued certificates. Those who use self-signed certificates should make sure to copy their Certification Authority certificate, or their self signed certificate if using only one, to the trust store of your operating system. As a workaround, one can ensure Sydent's emails fail to send by setting the configured SMTP server to a loopback or non-routable address under one's control which does not have a listening SMTP server.

CVSS 9.3 · Crítica · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • sydent

    Versiones
    • < 2.5.6: Afectada

    Sin corrección publicada

  • matrix-sydent PyPI

    Versiones
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.4.5
    • 2.4.6
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.5.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.5.6

    Actualiza a 2.5.6

  • matrix-sydent PyPI

    Versiones
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.4.5
    • 2.4.6
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.5.5
    Intervalos de versiones afectados
    • GIT: < 1cd748307c6b168b66154e6c4db715d4b9551261
    • ECOSYSTEM: < 2.5.6

    Actualiza a 2.5.6

  • matrix-sydent Ubuntu:22.04:LTS

    Versiones
    • 2.5.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • matrix-sydent Ubuntu:24.04:LTS

    Versiones
    • 2.5.1-1.1
    • 2.5.1-1.1ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →