CVE-2023-41884
CVE-2023-41884 · ZoneMinder Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') in watch.php
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
ZoneMinder is a free, open source Closed-circuit television software application. In WWW/AJAX/watch.php, Line: 51 takes a few parameter in sql query without sanitizing it which makes it vulnerable to sql injection. This vulnerability is fixed in 1.36.34.
CVSS 7.1 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
zoneminder
- Versiones
- < 1.36.34: Afectada
Sin corrección publicada
zoneminder Debian:12
- Versiones
- 1.36.33+dfsg1-1
- 1.36.35+dfsg1-1
- 1.36.37+dfsg1-1
- 1.36.37+dfsg1-1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
zoneminder Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.36.35+dfsg1-1
Actualiza a 1.36.35+dfsg1-1
zoneminder Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.36.35+dfsg1-1
Actualiza a 1.36.35+dfsg1-1
zoneminder Ubuntu:Pro:16.04:LTS
- Versiones
- 1.28.1-8
- 1.29.0+dfsg-1
- 1.29.0+dfsg-1ubuntu1
- 1.29.0+dfsg-1ubuntu2
- 1.29.0+dfsg-1ubuntu2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
zoneminder Ubuntu:Pro:20.04:LTS
- Versiones
- 1.32.3-2build1
- 1.32.3-2ubuntu1
- 1.32.3-2ubuntu2
- 1.32.3-2ubuntu2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
zoneminder Ubuntu:Pro:22.04:LTS
- Versiones
- 1.36.7+dfsg1-1
- 1.36.10+dfsg1-1
- 1.36.11+dfsg1-1
- 1.36.12+dfsg1-1
- 1.36.12+dfsg1-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
zoneminder Ubuntu:24.04:LTS
- Versiones
- 1.36.33+dfsg1-1build1
- 1.36.33+dfsg1-1build2
- 1.36.33+dfsg1-1build3
- 1.36.33+dfsg1-1build4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
zoneminder Ubuntu:25.10
- Versiones
- 1.36.35+dfsg1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
zoneminder Ubuntu:26.10
- Versiones
- 1.36.37+dfsg1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
zoneminder Ubuntu:26.04:LTS
- Versiones
- 1.36.35+dfsg1-1
- 1.36.37+dfsg1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/ZoneMinder/zoneminder/security/advisories/GHSA-2qp3-fwpv-mc96
- https://github.com/ZoneMinder/zoneminder/commit/677f6a31551f128554f7b0110a52fd76453a657a
- https://github.com/ZoneMinder/zoneminder/commit/a194fe81d34c5eea2ab1dc18dc8df615fca634a6
- https://nvd.nist.gov/vuln/detail/CVE-2023-41884