CVE-2023-42795
CVE-2023-42795 · Apache Tomcat: Failure during request clean-up leads to sensitive data leaking to subsequent requests
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Incomplete Cleanup vulnerability in Apache Tomcat.When recycling various internal objects in Apache Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.80 and from 8.5.0 through 8.5.93, an error could cause Tomcat to skip some parts of the recycling process leading to information leaking from the current request/response to the next. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fixes the issue.
CVSS 5.3 · Media · EPSS 2,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
apache tomcat
- Versiones
- ≥ 11.0.0-M1, ≤ 11.0.0-M11: Afectada (semver)
- ≥ 10.1.0-M1, ≤ 10.1.13: Afectada (semver)
- ≥ 9.0.0-M1, ≤ 9.0.80: Afectada (semver)
- ≥ 8.5.0, ≤ 8.5.93: Afectada (semver)
- ≥ 3, < 8.5.0: Desconocido (semver)
- ≥ 10.0.0-M1, ≤ 10.0.27: Desconocido (semver)
Sin corrección publicada
tomcat10 Debian:12
- Versiones
- 10.1.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.6-1+deb12u1
Actualiza a 10.1.6-1+deb12u1
tomcat10 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.14-1
Actualiza a 10.1.14-1
tomcat10 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.14-1
Actualiza a 10.1.14-1
tomcat9 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat9 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat9 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat6 Ubuntu:Pro:14.04:LTS
- Versiones
- 6.0.37-1
- 6.0.39-1
- 6.0.39-1ubuntu0.1
- 6.0.39-1ubuntu0.1+esm1
- 6.0.39-1ubuntu0.1+esm2
- 6.0.39-1ubuntu0.1+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat7 Ubuntu:Pro:14.04:LTS
- Versiones
- 7.0.42-1
- 7.0.47-1
- 7.0.50-1
- 7.0.52-1
- 7.0.52-1ubuntu0.1
- 7.0.52-1ubuntu0.3
- 7.0.52-1ubuntu0.6
- 7.0.52-1ubuntu0.7
- 7.0.52-1ubuntu0.8
- 7.0.52-1ubuntu0.9
- 7.0.52-1ubuntu0.10
- 7.0.52-1ubuntu0.11
- 7.0.52-1ubuntu0.13
- 7.0.52-1ubuntu0.14
- 7.0.52-1ubuntu0.15
- 7.0.52-1ubuntu0.16
- 7.0.52-1ubuntu0.16+esm1
- 7.0.52-1ubuntu0.16+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat8 Ubuntu:Pro:16.04:LTS
- Versiones
- 8.0.26-1
- 8.0.28-1
- 8.0.30-1
- 8.0.32-1
- 8.0.32-1ubuntu1
- 8.0.32-1ubuntu1.1
- 8.0.32-1ubuntu1.2
- 8.0.32-1ubuntu1.3
- 8.0.32-1ubuntu1.4
- 8.0.32-1ubuntu1.5
- 8.0.32-1ubuntu1.6
- 8.0.32-1ubuntu1.7
- 8.0.32-1ubuntu1.8
- 8.0.32-1ubuntu1.9
- 8.0.32-1ubuntu1.10
- 8.0.32-1ubuntu1.11
- 8.0.32-1ubuntu1.13
- 8.0.32-1ubuntu1.13+esm1
- 8.0.32-1ubuntu1.13+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat7 Ubuntu:Pro:16.04:LTS
- Versiones
- 7.0.64-1
- 7.0.68-1
- 7.0.68-1ubuntu0.1
- 7.0.68-1ubuntu0.3
- 7.0.68-1ubuntu0.4
- 7.0.68-1ubuntu0.4+esm1
- 7.0.68-1ubuntu0.4+esm2
- 7.0.68-1ubuntu0.4+esm3
- 7.0.68-1ubuntu0.4+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat8 Ubuntu:Pro:18.04:LTS
- Versiones
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- 8.5.39-1ubuntu1~18.04.3+esm1
- 8.5.39-1ubuntu1~18.04.3+esm2
- 8.5.39-1ubuntu1~18.04.3+esm3
- 8.5.39-1ubuntu1~18.04.3+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.5.39-1ubuntu1~18.04.3+esm5
Actualiza a 8.5.39-1ubuntu1~18.04.3+esm5
tomcat9 Ubuntu:Pro:18.04:LTS
- Versiones
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm4
Actualiza a 9.0.16-3ubuntu0.18.04.2+esm4
tomcat9 Ubuntu:20.04:LTS
- Versiones
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.31-1ubuntu0.8
Actualiza a 9.0.31-1ubuntu0.8
tomcat9 Ubuntu:Pro:22.04:LTS
- Versiones
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.58-1ubuntu0.1+esm4
Actualiza a 9.0.58-1ubuntu0.1+esm4
tomcat9 Ubuntu:Pro:24.04:LTS
- Versiones
- 9.0.70-1ubuntu1
- 9.0.70-2
- 9.0.70-2ubuntu0.1
- 9.0.70-2ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2ubuntu0.1+esm2
Actualiza a 9.0.70-2ubuntu0.1+esm2
tomcat9 Ubuntu:25.10
- Versiones
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2ubuntu3
Actualiza a 9.0.70-2ubuntu3
Fuentes originales
- https://lists.apache.org/thread/065jfyo583490r9j2v73nhpyxdob56lw
- http://www.openwall.com/lists/oss-security/2023/10/10/9
- https://www.debian.org/security/2023/dsa-5522
- https://www.debian.org/security/2023/dsa-5521
- https://lists.debian.org/debian-lts-announce/2023/10/msg00020.html
- https://security.netapp.com/advisory/ntap-20231103-0007/
- https://nvd.nist.gov/vuln/detail/CVE-2023-42795