CVE-2023-45802
CVE-2023-45802 · Apache HTTP Server: HTTP/2 stream memory not reclaimed right away on RST
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
When a HTTP/2 stream was reset (RST frame) by a client, there was a time window were the request's memory resources were not reclaimed immediately. Instead, de-allocation was deferred to connection close. A client could send new requests and resets, keeping the connection busy and open and causing the memory footprint to keep on growing. On connection close, all resources were reclaimed, but the process might run out of memory before that. This was found by the reporter during testing of CVE-2023-44487 (HTTP/2 Rapid Reset Exploit) with their own test client. During "normal" HTTP/2 use, the probability to hit this bug is very low. The kept memory would not become noticeable before the connection closes or times out. Users are recommended to upgrade to version 2.4.58, which fixes the issue.
CVSS 5.9 · Media · EPSS 3,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · web
Productos y versiones afectados
apache httpd
- Versiones
- ≥ 2.4.17, ≤ 2.4.57: Afectada (semver)
Sin corrección publicada
apache2 Debian:12
- Versiones
- 2.4.57-2
- 2.4.57-3
- 2.4.58-1
- 2.4.59-1~deb10u1
- 2.4.59-1~deb11u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.59-1~deb12u1
Actualiza a 2.4.59-1~deb12u1
apache2 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.58-1
Actualiza a 2.4.58-1
apache2 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.58-1
Actualiza a 2.4.58-1
apache2 Ubuntu:Pro:18.04:LTS
- Versiones
- 2.4.27-2ubuntu3
- 2.4.29-1ubuntu1
- 2.4.29-1ubuntu2
- 2.4.29-1ubuntu3
- 2.4.29-1ubuntu4
- 2.4.29-1ubuntu4.1
- 2.4.29-1ubuntu4.2
- 2.4.29-1ubuntu4.3
- 2.4.29-1ubuntu4.4
- 2.4.29-1ubuntu4.5
- 2.4.29-1ubuntu4.6
- 2.4.29-1ubuntu4.7
- 2.4.29-1ubuntu4.8
- 2.4.29-1ubuntu4.10
- 2.4.29-1ubuntu4.11
- 2.4.29-1ubuntu4.12
- 2.4.29-1ubuntu4.13
- 2.4.29-1ubuntu4.14
- 2.4.29-1ubuntu4.16
- 2.4.29-1ubuntu4.17
- 2.4.29-1ubuntu4.18
- 2.4.29-1ubuntu4.19
- 2.4.29-1ubuntu4.20
- 2.4.29-1ubuntu4.21
- 2.4.29-1ubuntu4.22
- 2.4.29-1ubuntu4.23
- 2.4.29-1ubuntu4.24
- 2.4.29-1ubuntu4.25
- 2.4.29-1ubuntu4.26
- 2.4.29-1ubuntu4.27
- 2.4.29-1ubuntu4.27+esm1
- 2.4.29-1ubuntu4.27+esm2
- 2.4.29-1ubuntu4.27+esm3
- 2.4.29-1ubuntu4.27+esm4
- 2.4.29-1ubuntu4.27+esm6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.29-1ubuntu4.27+esm7
Actualiza a 2.4.29-1ubuntu4.27+esm7
apache2 Ubuntu:20.04:LTS
- Versiones
- 2.4.41-1ubuntu1
- 2.4.41-4ubuntu1
- 2.4.41-4ubuntu2
- 2.4.41-4ubuntu3
- 2.4.41-4ubuntu3.1
- 2.4.41-4ubuntu3.3
- 2.4.41-4ubuntu3.4
- 2.4.41-4ubuntu3.5
- 2.4.41-4ubuntu3.6
- 2.4.41-4ubuntu3.7
- 2.4.41-4ubuntu3.8
- 2.4.41-4ubuntu3.9
- 2.4.41-4ubuntu3.10
- 2.4.41-4ubuntu3.11
- 2.4.41-4ubuntu3.12
- 2.4.41-4ubuntu3.13
- 2.4.41-4ubuntu3.14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.41-4ubuntu3.15
Actualiza a 2.4.41-4ubuntu3.15
apache2 Ubuntu:22.04:LTS
- Versiones
- 2.4.48-3.1ubuntu3
- 2.4.48-3.1ubuntu4
- 2.4.51-2ubuntu1
- 2.4.52-1ubuntu1
- 2.4.52-1ubuntu2
- 2.4.52-1ubuntu4
- 2.4.52-1ubuntu4.1
- 2.4.52-1ubuntu4.2
- 2.4.52-1ubuntu4.3
- 2.4.52-1ubuntu4.4
- 2.4.52-1ubuntu4.5
- 2.4.52-1ubuntu4.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.52-1ubuntu4.7
Actualiza a 2.4.52-1ubuntu4.7
apache2 Ubuntu:24.04:LTS
- Versiones
- 2.4.57-2ubuntu2
- 2.4.57-2ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.58-1ubuntu1
Actualiza a 2.4.58-1ubuntu1
Fuentes originales
- https://httpd.apache.org/security/vulnerabilities_24.html
- https://lists.fedoraproject.org/archives/list/[email protected]/message/BFQD3KUEMFBHPAPBGLWQC34L4OWL5HAZ/
- https://security.netapp.com/advisory/ntap-20231027-0011/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/2MBEPPC36UBVOZZNAXFHKLFGSLCMN5LI/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/WE2I52RHNNU42PX6NZ2RBUHSFFJ2LVZX/
- https://lists.debian.org/debian-lts-announce/2024/05/msg00013.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-45802