p PatchFirst

CVE-2023-46288

CVE-2023-46288 · Apache Airflow: Sensitive parameters exposed in API when "non-sensitive-only" configuration is set

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Airflow.This issue affects Apache Airflow from 2.4.0 to 2.7.0. Sensitive configuration information has been exposed to authenticated users with the ability to read configuration via Airflow REST API for configuration even when the expose_config option is set to non-sensitive-only. The expose_config option is False by default. It is recommended to upgrade to a version that is not affected if you set expose_config to non-sensitive-only configuration. This is a different error than CVE-2023-45348 which allows authenticated user to retrieve individual configuration values in 2.7.* by specially crafting their request (solved in 2.7.2). Users are recommended to upgrade to version 2.7.2, which fixes the issue and additionally fixes CVE-2023-45348.

CVSS 5.3 · Media · EPSS 1,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • apache airflow

    Versiones
    • ≥ 2.4.0, < 2.7.0: Afectada (semver)

    Actualiza a 2.7.0

  • apache-airflow PyPI

    Versiones
    • 2.4.0
    • 2.4.1
    • 2.4.1rc1
    • 2.4.2
    • 2.4.2rc1
    • 2.4.3
    • 2.4.3rc1
    • 2.5.0
    • 2.5.0rc1
    • 2.5.0rc2
    • 2.5.0rc3
    • 2.5.1
    • 2.5.1rc1
    • 2.5.1rc2
    • 2.5.2
    • 2.5.2rc1
    • 2.5.2rc2
    • 2.5.3
    • 2.5.3rc1
    • 2.5.3rc2
    • 2.6.0
    • 2.6.0b1
    • 2.6.0rc1
    • 2.6.0rc2
    • 2.6.0rc3
    • 2.6.0rc4
    • 2.6.0rc5
    • 2.6.1
    • 2.6.1rc1
    • 2.6.1rc2
    • 2.6.1rc3
    • 2.6.2
    • 2.6.2rc1
    • 2.6.2rc2
    • 2.6.3
    • 2.6.3rc1
    • 2.7.0
    • 2.7.0b1
    • 2.7.0rc1
    • 2.7.0rc2
    • 2.7.1
    • 2.7.1rc1
    • 2.7.1rc2
    • 2.7.2rc1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.4.0, < 2.7.2

    Actualiza a 2.7.2

  • apache-airflow PyPI

    Versiones
    • 2.4.0
    • 2.4.1
    • 2.4.1rc1
    • 2.4.2
    • 2.4.2rc1
    • 2.4.3
    • 2.4.3rc1
    • 2.5.0
    • 2.5.0rc1
    • 2.5.0rc2
    • 2.5.0rc3
    • 2.5.1
    • 2.5.1rc1
    • 2.5.1rc2
    • 2.5.2
    • 2.5.2rc1
    • 2.5.2rc2
    • 2.5.3
    • 2.5.3rc1
    • 2.5.3rc2
    • 2.6.0
    • 2.6.0b1
    • 2.6.0rc1
    • 2.6.0rc2
    • 2.6.0rc3
    • 2.6.0rc4
    • 2.6.0rc5
    • 2.6.1
    • 2.6.1rc1
    • 2.6.1rc2
    • 2.6.1rc3
    • 2.6.2
    • 2.6.2rc1
    • 2.6.2rc2
    • 2.6.3
    • 2.6.3rc1
    • 2.7.0b1
    • 2.7.0rc1
    • 2.7.0rc2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.4.0, < 2.7.0

    Actualiza a 2.7.0

Fuentes originales

Comprueba tu servidor →