p PatchFirst

CVE-2023-47248

CVE-2023-47248 · PyArrow, PyArrow: Arbitrary code execution when loading a malicious data file

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files). This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings. It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon. If it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.

CVSS 9.8 · Crítica · EPSS 14,5% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • pyarrow

    Versiones
    • ≥ 0.14.0, ≤ 14.0.0: Afectada (semver)

    Sin corrección publicada

  • pyarrow PyPI

    Versiones
    • 0.14.0
    • 0.14.1
    • 0.15.0
    • 0.15.1
    • 0.16.0
    • 0.17.0
    • 0.17.1
    • 1.0.0
    • 1.0.1
    • 10.0.0
    • 10.0.1
    • 11.0.0
    • 12.0.0
    • 12.0.1
    • 13.0.0
    • 14.0.0
    • 2.0.0
    • 3.0.0
    • 4.0.0
    • 4.0.1
    • 5.0.0
    • 6.0.0
    • 6.0.1
    • 7.0.0
    • 8.0.0
    • 9.0.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.14.0, < 14.0.1

    Actualiza a 14.0.1

Fuentes originales

Comprueba tu servidor →