p PatchFirst

CVE-2023-6129

CVE-2023-6129 · POLY1305 MAC implementation corrupts vector registers on PowerPC

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Issue summary: The POLY1305 MAC (message authentication code) implementation contains a bug that might corrupt the internal state of applications running on PowerPC CPU based platforms if the CPU provides vector instructions. Impact summary: If an attacker can influence whether the POLY1305 MAC algorithm is used, the application state might be corrupted with various application dependent consequences. The POLY1305 MAC (message authentication code) implementation in OpenSSL for PowerPC CPUs restores the contents of vector registers in a different order than they are saved. Thus the contents of some of these vector registers are corrupted when returning to the caller. The vulnerable code is used only on newer PowerPC processors supporting the PowerISA 2.07 instructions. The consequences of this kind of internal application state corruption can be various - from no consequences, if the calling application does not depend on the contents of non-volatile XMM registers at all, to the worst consequences, where the attacker could get complete control of the application process. However unless the compiler uses the vector registers for storing pointers, the most likely consequence, if any, would be an incorrect result of some application dependent calculations or a crash leading to a denial of service. The POLY1305 MAC algorithm is most frequently used as part of the CHACHA20-POLY1305 AEAD (authenticated encryption with associated data) algorithm. The most common usage of this AEAD cipher is with TLS protocol versions 1.2 and 1.3. If this cipher is enabled on the server a malicious client can influence whether this AEAD cipher is used. This implies that TLS server applications using OpenSSL can be potentially impacted. However we are currently not aware of any concrete application that would be affected by this issue therefore we consider this a Low severity security issue.

CVSS 6.5 · Media · EPSS 2,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · network

Productos y versiones afectados

  • openssl

    Versiones
    • ≥ 3.2.0, < 3.2.1: Afectada (semver)
    • ≥ 3.1.0, < 3.1.5: Afectada (semver)
    • ≥ 3.0.0, < 3.0.13: Afectada (semver)

    Actualiza a 3.0.13; Actualiza a 3.1.5; Actualiza a 3.2.1

  • openssl Debian:12

    Versiones
    • 3.0.10-1
    • 3.0.10-1~deb12u1
    • 3.0.11-1
    • 3.0.11-1~deb12u1
    • 3.0.11-1~deb12u2
    • 3.0.12-1
    • 3.0.12-2
    • 3.0.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.13-1~deb12u1

    Actualiza a 3.0.13-1~deb12u1

  • openssl Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.5-1

    Actualiza a 3.1.5-1

  • openssl Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.5-1

    Actualiza a 3.1.5-1

  • openssl Ubuntu:22.04:LTS

    Versiones
    • 1.1.1l-1ubuntu1
    • 3.0.0-1ubuntu1
    • 3.0.1-0ubuntu1
    • 3.0.2-0ubuntu1
    • 3.0.2-0ubuntu1.1
    • 3.0.2-0ubuntu1.2
    • 3.0.2-0ubuntu1.4
    • 3.0.2-0ubuntu1.5
    • 3.0.2-0ubuntu1.6
    • 3.0.2-0ubuntu1.7
    • 3.0.2-0ubuntu1.8
    • 3.0.2-0ubuntu1.9
    • 3.0.2-0ubuntu1.10
    • 3.0.2-0ubuntu1.12
    • 3.0.2-0ubuntu1.13
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.2-0ubuntu1.14

    Actualiza a 3.0.2-0ubuntu1.14

  • nodejs Ubuntu:Pro:22.04:LTS

    Versiones
    • 12.22.5~dfsg-5ubuntu1
    • 12.22.7~dfsg-2ubuntu1
    • 12.22.7~dfsg-2ubuntu3
    • 12.22.9~dfsg-1ubuntu2
    • 12.22.9~dfsg-1ubuntu3
    • 12.22.9~dfsg-1ubuntu3.1
    • 12.22.9~dfsg-1ubuntu3.2
    • 12.22.9~dfsg-1ubuntu3.3
    • 12.22.9~dfsg-1ubuntu3.4
    • 12.22.9~dfsg-1ubuntu3.5
    • 12.22.9~dfsg-1ubuntu3.6
    • 12.22.9~dfsg-1ubuntu3.6+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openssl Ubuntu:Pro:FIPS-preview:22.04:LTS

    Versiones
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openssl Ubuntu:Pro:FIPS-updates:22.04:LTS

    Versiones
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.2-0ubuntu1.14+Fips1

    Actualiza a 3.0.2-0ubuntu1.14+Fips1

  • openssl Ubuntu:24.04:LTS

    Versiones
    • 3.0.10-1ubuntu2
    • 3.0.10-1ubuntu2.1
    • 3.0.10-1ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.10-1ubuntu4

    Actualiza a 3.0.10-1ubuntu4

Fuentes originales

Comprueba tu servidor →