p PatchFirst

CVE-2023-6237

CVE-2023-6237 · Excessive time spent checking invalid RSA public keys

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Issue summary: Checking excessively long invalid RSA public keys may take a long time. Impact summary: Applications that use the function EVP_PKEY_public_check() to check RSA public keys may experience long delays. Where the key that is being checked has been obtained from an untrusted source this may lead to a Denial of Service. When function EVP_PKEY_public_check() is called on RSA public keys, a computation is done to confirm that the RSA modulus, n, is composite. For valid RSA keys, n is a product of two or more large primes and this computation completes quickly. However, if n is an overly large prime, then this computation would take a long time. An application that calls EVP_PKEY_public_check() and supplies an RSA key obtained from an untrusted source could be vulnerable to a Denial of Service attack. The function EVP_PKEY_public_check() is not called from other OpenSSL functions however it is called from the OpenSSL pkey command line application. For that reason that application is also vulnerable if used with the '-pubin' and '-check' options on untrusted data. The OpenSSL SSL/TLS implementation is not affected by this issue. The OpenSSL 3.0 and 3.1 FIPS providers are affected by this issue.

CVSS 5.9 · Media · EPSS 2,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · network

Productos y versiones afectados

  • openssl

    Versiones
    • ≥ 3.0.0, < 3.0.13: Afectada (semver)
    • ≥ 3.1.0, < 3.1.5: Afectada (semver)
    • ≥ 3.2.0, < 3.2.1: Afectada (semver)

    Actualiza a 3.0.13; Actualiza a 3.1.5; Actualiza a 3.2.1

  • openssl Debian:12

    Versiones
    • 3.0.10-1
    • 3.0.10-1~deb12u1
    • 3.0.11-1
    • 3.0.11-1~deb12u1
    • 3.0.11-1~deb12u2
    • 3.0.12-1
    • 3.0.12-2
    • 3.0.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.13-1~deb12u1

    Actualiza a 3.0.13-1~deb12u1

  • openssl Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.5-1

    Actualiza a 3.1.5-1

  • openssl Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.5-1

    Actualiza a 3.1.5-1

  • openssl Ubuntu:22.04:LTS

    Versiones
    • 1.1.1l-1ubuntu1
    • 3.0.0-1ubuntu1
    • 3.0.1-0ubuntu1
    • 3.0.2-0ubuntu1
    • 3.0.2-0ubuntu1.1
    • 3.0.2-0ubuntu1.2
    • 3.0.2-0ubuntu1.4
    • 3.0.2-0ubuntu1.5
    • 3.0.2-0ubuntu1.6
    • 3.0.2-0ubuntu1.7
    • 3.0.2-0ubuntu1.8
    • 3.0.2-0ubuntu1.9
    • 3.0.2-0ubuntu1.10
    • 3.0.2-0ubuntu1.12
    • 3.0.2-0ubuntu1.13
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.2-0ubuntu1.14

    Actualiza a 3.0.2-0ubuntu1.14

  • nodejs Ubuntu:Pro:22.04:LTS

    Versiones
    • 12.22.5~dfsg-5ubuntu1
    • 12.22.7~dfsg-2ubuntu1
    • 12.22.7~dfsg-2ubuntu3
    • 12.22.9~dfsg-1ubuntu2
    • 12.22.9~dfsg-1ubuntu3
    • 12.22.9~dfsg-1ubuntu3.1
    • 12.22.9~dfsg-1ubuntu3.2
    • 12.22.9~dfsg-1ubuntu3.3
    • 12.22.9~dfsg-1ubuntu3.4
    • 12.22.9~dfsg-1ubuntu3.5
    • 12.22.9~dfsg-1ubuntu3.6
    • 12.22.9~dfsg-1ubuntu3.6+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openssl Ubuntu:Pro:FIPS-preview:22.04:LTS

    Versiones
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openssl Ubuntu:Pro:FIPS-updates:22.04:LTS

    Versiones
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.2-0ubuntu1.14+Fips1

    Actualiza a 3.0.2-0ubuntu1.14+Fips1

  • edk2 Ubuntu:24.04:LTS

    Versiones
    • 2023.05-2
    • 2023.11-2
    • 2023.11-3
    • 2023.11-4
    • 2023.11-5
    • 2023.11-6
    • 2023.11-8
    • 2024.02-1
    • 2024.02-2
    • 2024.02-2ubuntu0.1
    • 2024.02-2ubuntu0.3
    • 2024.02-2ubuntu0.4
    • 2024.02-2ubuntu0.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2024.02-2ubuntu0.6

    Actualiza a 2024.02-2ubuntu0.6

  • openssl Ubuntu:24.04:LTS

    Versiones
    • 3.0.10-1ubuntu2
    • 3.0.10-1ubuntu2.1
    • 3.0.10-1ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.10-1ubuntu4

    Actualiza a 3.0.10-1ubuntu4

Fuentes originales

Comprueba tu servidor →