CVE-2024-24549
CVE-2024-24549 · Apache Tomcat: HTTP/2 header handling DoS
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
CVSS 7.5 · Alta · EPSS 23,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
apache tomcat
- Versiones
- ≥ 11.0.0-M1, ≤ 11.0.0-M16: Afectada (semver)
- ≥ 10.1.0-M1, ≤ 10.1.18: Afectada (semver)
- ≥ 9.0.0-M1, ≤ 9.0.85: Afectada (semver)
- ≥ 8.5.0, ≤ 8.5.98: Afectada (semver)
- ≥ 10.0.0-M1, ≤ 10.0.27: Desconocido (semver)
Sin corrección publicada
tomcat10 Debian:12
- Versiones
- 10.1.6-1
- 10.1.6-1+deb12u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.6-1+deb12u2
Actualiza a 10.1.6-1+deb12u2
tomcat10 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.20-1
Actualiza a 10.1.20-1
tomcat10 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.20-1
Actualiza a 10.1.20-1
tomcat9 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat9 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat9 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat8 Ubuntu:Pro:18.04:LTS
- Versiones
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- 8.5.39-1ubuntu1~18.04.3+esm1
- 8.5.39-1ubuntu1~18.04.3+esm2
- 8.5.39-1ubuntu1~18.04.3+esm3
- 8.5.39-1ubuntu1~18.04.3+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.5.39-1ubuntu1~18.04.3+esm5
Actualiza a 8.5.39-1ubuntu1~18.04.3+esm5
tomcat9 Ubuntu:Pro:18.04:LTS
- Versiones
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- 9.0.16-3ubuntu0.18.04.2+esm4
- 9.0.16-3ubuntu0.18.04.2+esm5
- 9.0.16-3ubuntu0.18.04.2+esm6
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm7
Actualiza a 9.0.16-3ubuntu0.18.04.2+esm7
tomcat9 Ubuntu:Pro:20.04:LTS
- Versiones
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- 9.0.31-1ubuntu0.8
- 9.0.31-1ubuntu0.9
- 9.0.31-1ubuntu0.9+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.31-1ubuntu0.9+esm2
Actualiza a 9.0.31-1ubuntu0.9+esm2
tomcat9 Ubuntu:Pro:22.04:LTS
- Versiones
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- 9.0.58-1ubuntu0.1+esm4
- 9.0.58-1ubuntu0.2
- 9.0.58-1ubuntu0.2+esm1
- 9.0.58-1ubuntu0.2+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.58-1ubuntu0.2+esm3
Actualiza a 9.0.58-1ubuntu0.2+esm3
tomcat10 Ubuntu:Pro:24.04:LTS
- Versiones
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm2
Actualiza a 10.1.16-1ubuntu0.1~esm2
tomcat9 Ubuntu:Pro:24.04:LTS
- Versiones
- 9.0.70-1ubuntu1
- 9.0.70-2
- 9.0.70-2ubuntu0.1
- 9.0.70-2ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2ubuntu0.1+esm2
Actualiza a 9.0.70-2ubuntu0.1+esm2
tomcat9 Ubuntu:25.10
- Versiones
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2ubuntu3
Actualiza a 9.0.70-2ubuntu3
Fuentes originales
- https://lists.apache.org/thread/4c50rmomhbbsdgfjsgwlb51xdwfjdcvg
- https://security.netapp.com/advisory/ntap-20240402-0002/
- https://lists.debian.org/debian-lts-announce/2024/04/msg00001.html
- http://www.openwall.com/lists/oss-security/2024/03/13/3
- https://lists.fedoraproject.org/archives/list/[email protected]/message/736G4GPZWS2DSQO5WKXO3G6OMZKFEK55/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/3UWIS5MMGYDZBLJYT674ZI5AWFHDZ46B/
- https://nvd.nist.gov/vuln/detail/CVE-2024-24549