p PatchFirst

CVE-2024-24826

CVE-2024-24826 · Out-of-bounds read in QuickTimeVideo::NikonTagsDecoder in Exiv2

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 version v0.28.1. The vulnerable function, `QuickTimeVideo::NikonTagsDecoder`, was new in v0.28.0, so Exiv2 versions before v0.28 are _not_ affected. The out-of-bounds read is triggered when Exiv2 is used to read the metadata of a crafted video file. In most cases this out of bounds read will result in a crash. This bug is fixed in version v0.28.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 5.5 · Media · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • exiv2

    Versiones
    • >= 0.28.0, < 0.28.2: Afectada

    Sin corrección publicada

  • exiv2 Debian:12

    Versiones
    • 0.27.6-1
    • 0.28.0+dfsg-1
    • 0.28.0+dfsg-2
    • 0.28.0+dfsg-3
    • 0.28.0+dfsg-4
    • 0.28.1+dfsg-1
    • 0.28.1+dfsg-2
    • 0.28.1+dfsg-3
    • 0.28.2+dfsg-1
    • 0.28.3+dfsg-1
    • 0.28.3+dfsg-2
    • 0.28.4+dfsg-1
    • 0.28.4+dfsg-2
    • 0.28.5+dfsg-1
    • 0.28.7+dfsg-1
    • 0.28.7+dfsg-2
    • 0.28.8+dfsg-1
    • 0.28.9+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • exiv2 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.28.3+dfsg-2

    Actualiza a 0.28.3+dfsg-2

  • exiv2 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.28.3+dfsg-2

    Actualiza a 0.28.3+dfsg-2

  • exiv2 PyPI

    Versiones
    • 0.16.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.16.0, < 0.16.1

    Actualiza a 0.16.1

Fuentes originales

Comprueba tu servidor →