p PatchFirst

CVE-2024-26143

CVE-2024-26143 · Rails Possible XSS Vulnerability in Action Controller

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Rails is a web-application framework. There is a possible XSS vulnerability when using the translation helpers in Action Controller. Applications using translation methods like translate, or t on a controller, with a key ending in "_html", a :default key which contains untrusted user input, and the resulting string is used in a view, may be susceptible to an XSS vulnerability. The vulnerability is fixed in 7.1.3.1 and 7.0.8.1.

CVSS 6.1 · Media · EPSS 1,0%

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • rails

    Versiones
    • >= 7.0.0, < 7.0.8.1: Afectada
    • >= 7.1.0, < 7.1.3.1: Afectada

    Sin corrección publicada

  • rails Ubuntu:Pro:16.04:LTS

    Versiones
    • 2:4.1.10-1
    • 2:4.2.5-1
    • 2:4.2.5.1-1
    • 2:4.2.5.2-2
    • 2:4.2.6-1
    • 2:4.2.6-1ubuntu0.1~esm1
    • 2:4.2.6-1ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:18.04:LTS

    Versiones
    • 2:4.2.9-2
    • 2:4.2.9-4
    • 2:4.2.10-0ubuntu4
    • 2:4.2.10-0ubuntu4+esm1
    • 2:4.2.10-0ubuntu4+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:20.04:LTS

    Versiones
    • 2:5.2.2.1+dfsg-1ubuntu1
    • 2:5.2.3+dfsg-3
    • 2:5.2.3+dfsg-3ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:22.04:LTS

    Versiones
    • 2:6.0.3.7+dfsg-2
    • 2:6.1.4.1+dfsg-8ubuntu2
    • 2:6.1.4.1+dfsg-8ubuntu2+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:24.04:LTS

    Versiones
    • 2:6.1.7.3+dfsg-2build1
    • 2:6.1.7.3+dfsg-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:25.10

    Versiones
    • 2:6.1.7.3+dfsg-7
    • 2:7.2.2.1+dfsg-7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:26.10

    Versiones
    • 2:7.2.3+dfsg-2
    • 2:7.2.3.2+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:26.04:LTS

    Versiones
    • 2:7.2.2.1+dfsg-7
    • 2:7.2.2.2+dfsg-2
    • 2:7.2.3+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →