p PatchFirst

CVE-2024-27091

CVE-2024-27091 · GeoNode stored XSS to full account takeover

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed. This vulnerability is fixed in 4.2.3.

CVSS 6.1 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • geonode

    Versiones
    • >= 3.2.0, < 4.2.3: Afectada

    Sin corrección publicada

  • geonode PyPI

    Versiones
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.3.post1
    • 3.2.4
    • 3.3.0
    • 3.3.1
    • 3.3.1.post1
    • 3.3.2
    • 3.3.2.post1
    • 3.3.2.post2
    • 3.3.3
    • 4.0.0
    • 4.0.0.post1
    • 4.0.0rc0
    • 4.0.0rc1
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.1.0
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.1.3.post1
    • 4.1.4
    • 4.1.5
    • 4.2.0
    • 4.2.1
    • 4.2.2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 3.2.1, < 4.2.3

    Actualiza a 4.2.3

Fuentes originales

Comprueba tu servidor →