CVE-2024-28245
CVE-2024-28245 · KaTeX's \includegraphics does not escape filename
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using `\includegraphics` that runs arbitrary JavaScript, or generate invalid HTML. Upgrade to KaTeX v0.16.10 to remove this vulnerability.
CVSS 6.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
katex
- Versiones
- >= 0.11.0, < 0.6.10: Afectada
Sin corrección publicada
node-katex Debian:12
- Versiones
- 0.16.10+~cs6.1.0-1
- 0.16.10+~cs6.1.0-2
- 0.16.10+~cs6.1.0-3
- 0.16.10+~cs6.1.0-4
- 0.16.10+~cs6.1.0-5
- 0.16.10+~cs6.1.0-6
- 0.16.10+~cs6.1.0-7
- 0.16.10+~cs6.1.0-8
- 0.16.10+~cs6.1.0-9
- 0.16.4+~cs6.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-katex Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16.10+~cs6.1.0-1
Actualiza a 0.16.10+~cs6.1.0-1
node-katex Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16.10+~cs6.1.0-1
Actualiza a 0.16.10+~cs6.1.0-1
katex npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.11.0, < 0.16.10
Actualiza a 0.16.10
node-katex Ubuntu:Pro:22.04:LTS
- Versiones
- 0.10.2+dfsg-8
- 0.10.2+dfsg-9
- 0.10.2+dfsg-10
- 0.13.11+~cs6.0.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.13.11+~cs6.0.0-2ubuntu0.1~esm1
Actualiza a 0.13.11+~cs6.0.0-2ubuntu0.1~esm1