CVE-2024-29203
CVE-2024-29203 · TinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframes
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content insertion code. This allowed `iframe` elements containing malicious code to execute when inserted into the editor. These `iframe` elements are restricted in their permissions by same-origin browser protections, but could still trigger operations such as downloading of malicious assets. This vulnerability is fixed in 6.8.1.
CVSS 4.3 · Media · EPSS 0,7% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php · node
Productos y versiones afectados
tinymce
- Versiones
- < 6.8.1: Afectada
Sin corrección publicada
tinymce npm
- Intervalos de versiones afectados
- SEMVER: < 6.8.1
Actualiza a 6.8.1
tinymce NuGet
- Versiones
- 3.4.3.2
- 3.4.4
- 3.4.5
- 3.4.7
- 3.5.0
- 3.5.0.1
- 3.5.1
- 3.5.1.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.5.4.1
- 3.5.5
- 3.5.6
- 3.5.7
- 3.5.8
- 4.0.0
- 4.0.1
- 4.0.10
- 4.0.11
- 4.0.13
- 4.0.14
- 4.0.15
- 4.0.16
- 4.0.17
- 4.0.18
- 4.0.19
- 4.0.2
- 4.0.20
- 4.0.21
- 4.0.22
- 4.0.23
- 4.0.24
- 4.0.25
- 4.0.26
- 4.0.27
- 4.0.28
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.8
- 4.0.9
- 4.1.0
- 4.1.1
- 4.1.10
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1.7
- 4.1.8
- 4.1.9
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.11
- 4.3.12
- 4.3.13
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.5.0
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.5.8
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 4.6.4
- 4.6.5
- 4.6.6
- 4.6.7
- 4.7.0
- 4.7.10
- 4.7.11
- 4.7.12
- 4.7.13
- 4.7.3
- 4.7.4
- 4.7.5
- 4.7.6
- 4.7.7
- 4.7.8
- 4.7.9
- 4.8.0
- 4.8.1
- 4.8.2
- 4.8.3
- 4.8.4
- 4.8.5
- 4.9.0
- 4.9.1
- 4.9.10
- 4.9.11
- 4.9.2
- 4.9.3
- 4.9.4
- 4.9.5
- 4.9.6
- 4.9.7
- 4.9.8
- 4.9.9
- 5.0.0
- 5.0.1
- 5.0.10
- 5.0.11
- 5.0.12
- 5.0.13
- 5.0.14
- 5.0.15
- 5.0.16
- 5.0.2
- 5.0.3
- 5.0.4
- 5.0.5
- 5.0.6
- 5.0.7
- 5.0.8
- 5.0.9
- 5.1.0
- 5.1.1
- 5.1.2
- 5.1.3
- 5.1.4
- 5.1.5
- 5.1.6
- 5.10.0
- 5.10.1
- 5.10.2
- 5.10.3
- 5.10.4
- 5.10.5
- 5.10.6
- 5.10.7
- 5.10.8
- 5.10.9
- 5.2.0
- 5.2.1
- 5.2.2
- 5.3.0
- 5.3.1
- 5.3.2
- 5.4.0
- 5.4.1
- 5.4.2
- 5.5.0
- 5.5.1
- 5.6.0
- 5.6.1
- 5.6.2
- 5.7.0
- 5.7.1
- 5.8.0
- 5.8.1
- 5.8.2
- 5.9.0
- 5.9.1
- 5.9.2
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.1.0
- 6.1.1
- 6.1.2
- 6.2.0
- 6.3.0
- 6.3.1
- 6.3.2
- 6.4.0
- 6.4.1
- 6.4.2
- 6.5.0
- 6.5.1
- 6.6.2
- 6.7.0
- 6.7.1
- 6.7.2
- 6.7.3
- 6.8.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.8.1
Actualiza a 6.8.1
tinymce/tinymce Packagist
- Versiones
- 4.0.0
- 4.0.1
- 4.0.10
- 4.0.11
- 4.0.12
- 4.0.13
- 4.0.14
- 4.0.15
- 4.0.16
- 4.0.17
- 4.0.18
- 4.0.19
- 4.0.2
- 4.0.20
- 4.0.21
- 4.0.22
- 4.0.23
- 4.0.24
- 4.0.25
- 4.0.26
- 4.0.27
- 4.0.28
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.0.9
- 4.1.0
- 4.1.1
- 4.1.10
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1.7
- 4.1.8
- 4.1.9
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.11
- 4.3.12
- 4.3.13
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.5.0
- 4.5.1
- 4.5.12
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.5.8
- 4.5.9
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 4.6.4
- 4.6.5
- 4.6.6
- 4.6.7
- 4.7.0
- 4.7.1
- 4.7.10
- 4.7.11
- 4.7.12
- 4.7.13
- 4.7.2
- 4.7.3
- 4.7.4
- 4.7.5
- 4.7.6
- 4.7.7
- 4.7.8
- 4.7.9
- 4.8.0
- 4.8.1
- 4.8.2
- 4.8.3
- 4.8.4
- 4.8.5
- 4.9.0
- 4.9.1
- 4.9.10
- 4.9.11
- 4.9.2
- 4.9.3
- 4.9.4
- 4.9.5
- 4.9.6
- 4.9.7
- 4.9.8
- 4.9.9
- 5.0.0
- 5.0.1
- 5.0.10
- 5.0.11
- 5.0.12
- 5.0.13
- 5.0.14
- 5.0.15
- 5.0.16
- 5.0.2
- 5.0.3
- 5.0.4
- 5.0.5
- 5.0.6
- 5.0.7
- 5.0.8
- 5.0.9
- 5.1.0
- 5.1.1
- 5.1.2
- 5.1.3
- 5.1.4
- 5.1.5
- 5.1.6
- 5.10.0
- 5.10.1
- 5.10.2
- 5.10.3
- 5.10.4
- 5.10.5
- 5.10.6
- 5.10.7
- 5.10.8
- 5.10.9
- 5.2.0
- 5.2.1
- 5.2.2
- 5.3.0
- 5.3.1
- 5.3.2
- 5.4.0
- 5.4.1
- 5.4.2
- 5.5.0
- 5.5.1
- 5.6.0
- 5.6.1
- 5.6.2
- 5.7.0
- 5.7.1
- 5.8.0
- 5.8.1
- 5.8.2
- 5.9.0
- 5.9.1
- 5.9.2
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.1.0
- 6.1.1
- 6.1.2
- 6.2.0
- 6.3.0
- 6.3.1
- 6.3.2
- 6.4.0
- 6.4.1
- 6.4.2
- 6.5.0
- 6.5.1
- 6.6.0
- 6.6.1
- 6.6.2
- 6.7.0
- 6.7.1
- 6.7.2
- 6.7.3
- 6.8.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.8.1
Actualiza a 6.8.1
tinymce Ubuntu:16.04:LTS
- Versiones
- 3.4.8+dfsg0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tinymce Ubuntu:18.04:LTS
- Versiones
- 3.4.8+dfsg0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tinymce Ubuntu:20.04:LTS
- Versiones
- 3.4.8+dfsg0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/tinymce/tinymce/security/advisories/GHSA-438c-3975-5x3f
- https://github.com/tinymce/tinymce/commit/bcdea2ad14e3c2cea40743fb48c63bba067ae6d1
- https://www.tiny.cloud/docs/tinymce/6/6.8.1-release-notes/#new-convert_unsafe_embeds-option-that-controls-whether-object-and-embed-elements-will-be-converted-to-more-restrictive-alternatives-namely-img-for-image-mime-types-video-for-video-mime-types-audio-audio-mime-types-or-iframe-for-other-or-unspecified-mime-types
- https://www.tiny.cloud/docs/tinymce/7/7.0-release-notes/#sandbox_iframes-editor-option-is-now-defaulted-to-true
- https://nvd.nist.gov/vuln/detail/CVE-2024-29203