p PatchFirst

CVE-2024-30266

CVE-2024-30266 · Wasmtime vulnerable to panic when using a dropped extenref-typed element segment

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

wasmtime is a runtime for WebAssembly. The 19.0.0 release of Wasmtime contains a regression introduced during its development which can lead to a guest WebAssembly module causing a panic in the host runtime. A valid WebAssembly module, when executed at runtime, may cause this panic. This vulnerability has been patched in version 19.0.1.

CVSS 3.3 · Baja · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • wasmtime

    Versiones
    • = 19.0.0: Afectada

    Sin corrección publicada

  • rust-wasmtime Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 21.0.2+dfsg-1

    Actualiza a 21.0.2+dfsg-1

  • rust-wasmtime Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 21.0.2+dfsg-1

    Actualiza a 21.0.2+dfsg-1

  • wasmtime PyPI

    Versiones
    • 0.0.1
    • 0.0.2
    • 0.11.0
    • 0.12.0
    • 0.15.0
    • 0.15.1
    • 0.16.0
    • 0.16.1
    • 0.17.0
    • 0.18.0
    • 0.18.1
    • 0.18.2
    • 0.19.0
    • 0.20.0
    • 0.21.0
    • 0.22.0
    • 0.23.0
    • 0.24.0
    • 0.25.0
    • 0.26.0
    • 0.27.0
    • 0.28.0
    • 0.28.1
    • 0.29.0
    • 0.30.0
    • 0.31.0
    • 0.32.0
    • 0.33.0
    • 0.34.0
    • 0.35.0
    • 0.36.0
    • 0.37.0
    • 0.38.0
    • 0.39.1
    • 0.40.0
    • 0.9.0
    • 1.0.0
    • 1.0.1
    • 10.0.0
    • 10.0.1
    • 11.0.0
    • 12.0.0
    • 13.0.0
    • 13.0.1
    • 13.0.2
    • 14.0.0
    • 15.0.0
    • 16.0.0
    • 17.0.0
    • 17.0.1
    • 18.0.0
    • 18.0.2
    • 19.0.0
    • 2.0.0
    • 3.0.0
    • 4.0.0
    • 5.0.0
    • 6.0.0
    • 7.0.0
    • 8.0.0
    • 8.0.1
    • 9.0.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≤ 19.0.0

    Sin corrección publicada

  • rust-wasmtime Ubuntu:24.04:LTS

    Versiones
    • 10.0.1+dfsg-7
    • 15.0.1+dfsg-4
    • 16.0.0+dfsg-2
    • 16.0.0+dfsg-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →